设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票指标公式——起爆点买入指标源码

来源:未知 编辑:admin 时间:2018-03-01
导读: 股市买卖操作的过程,第一步就是选择股价的起爆点进行买入操作,前提选好股票之后,那么股价的启动点可不是那么容易寻找的,所以在股票指标公式中,赢家财富网小编通过起爆点
 
  股市买卖操作的过程,第一步就是选择股价的起爆点进行买入操作,前提选好股票之后,那么股价的启动点可不是那么容易寻找的,所以在中,赢家财富网小编通过起爆点买入指标的公式源码进行简单的分析讲解。

  【起爆点买入】

  起涨——买入——抄底——上涨——卖出;本身就是一个简单的买卖交易过程,有不同的交易技巧进行支撑,而在源码中的表示是最为清晰的:

  DRAWGBK(O>C,RGB(48,41,124),RGB(0,0,0),0,'1',0);

  VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

  VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

  XG:=(FILTER((VAR4AA>90),45)),COLORYELLOW;

  STICKLINE(XG,150,0,4,0),COLOR000099;

  STICKLINE(XG,150,0,2,0),COLOR0000BB;

  STICKLINE(XG,150,0,1,0),COLOR0000DD;

  STICKLINE(XG,150,0,0.9,0),COLOR0000FF;

  DRAWTEXT(XG>0,130,'SI起暴点'),COLOR00C5FF;

  DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;

  DEA :=EMA(DIFF,9);

  MACD :=2*(DIFF-DEA);

  抄底1:=ABS((CROSS("MACD.DIF","MACD.DEA")

  &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.09,COLORLIMAGENTA,LINETHICK2;

  STICKLINE(抄底1,0,50,4,0),COLOR770077;

  STICKLINE(抄底1,0,50,3,0),COLOR990099;

  STICKLINE(抄底1,0,50,2,0),COLORBB00BB;

  STICKLINE(抄底1,0,50,1,0),COLORDD00DD;

  STICKLINE(抄底1,0,50,0.3,0),COLORFF00FF;

  DRAWTEXT(抄底1>0,38,'超级拐点'),COLOR00C5FF;

  反向钟摆线:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,20);

  DK:=CROSS(-5,反向钟摆线);

  STICKLINE(DK,0,50,4,0),COLOR770077;

  STICKLINE(DK,0,50,3,0),COLOR990099;

  STICKLINE(DK,0,50,2,0),COLORBB00BB;

  STICKLINE(DK,0,50,1,0),COLORDD00DD;

  STICKLINE(DK,0,50,0.3,0),COLORFF00FF;

  DRAWTEXT(DK>0,48,'终极低点'),COLOR00C5FF;

  VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

  VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

  VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

  VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);

  VAR6:=MA(VAR5,3);

  VAR7:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3) / CAPITAL));

  VAR8:=(((CLOSE - VAR7) / VAR7) * 100);

  VAR9:=((((REF(VAR8,1) < (0 - 40)) AND (VAR8 > REF(VAR8,1))) AND (REF(VAR8,1) < REF(VAR8,2))) AND ((VAR8 - REF(VAR8,1)) > 2.5));

  VARD:=REF(CLOSE,1);

  VARE:=((SMA(MAX((CLOSE - VARD),0),5,1) / SMA(ABS((CLOSE - VARD)),5,1)) * 100);

  VARF:=(((HIGH + LOW) + CLOSE) / 3);

  VAR10:=((VARF - MA(VARF,14)) / (0.015 * AVEDEV(VARF,14)));

  VAR11:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));

  VAR12:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));

  VAR13:=(VAR11 AND VAR12);

  VAR14:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 10))) AND (VAR3 <= (0 - 15))) AND (VAR4 <= (0 - 20)));

  VAR15:=(COUNT(VAR14,1) >= 1);

  VAR16:=(VAR13 AND VAR15);

  VAR17:=1;

  VAR18:=(CLOSE * VOL);

  VAR19:=EMA((((((MA(VAR18,4) / MA(VOL,4)) + (MA(VAR18,6) / MA(VOL,6))) + (MA(VAR18,13) / MA(VOL,13))) + (MA(VAR18,24) / MA(VOL,24))) / 4),1);

  VAR1A:=(1 * VAR19);

  VAR1B:=(VAR19 * 0.92);

  VAR1C:=EMA(CLOSE,34);

  VAR1D:=MA((VAR1C * 1.12),5);

  VAR1E:=MA((VAR1C * 0.82),5);

  VAR1F:=(CLOSE < VAR1E);

  VAR20:=((((((MA(AMOUNT,5) * VAR17) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < ((0 - 0.4) * VAR17));

  VAR21:=HHV(HIGH,500);

  VAR22:=LLV(LOW,500);

  VAR23:=HHV(HIGH,250);

  VAR24:=LLV(LOW,250);

  VAR25:=HHV(HIGH,125);

  VAR26:=LLV(LOW,125);

  VAR27:=MA(((((((VAR21 * 0.45) + (VAR23 * 0.5)) + VAR22) + VAR24) + VAR26) / 5),35);

  VAR28:=MA((((VAR23 * 0.62) + VAR26) / 2),35);

  VAR29:=MA((((VAR23 * 0.75) + VAR26) / 2),18);

  VAR2A:=MA((((((VAR23 * 0.93) + (VAR27 * 2)) + (VAR28 * 1.8)) + (VAR29 * 1.5)) / 4),18);

  VAR2B:=MA(((((VAR21 * 0.95) + (VAR27 * 3)) + (VAR28 * 2)) / 3),35);

  VAR2C:=VAR27;

  VAR2D:=VAR28;

  VAR2E:=VAR29;

  VAR2F:=VAR2A;

  VAR30:=VAR2B;

  VAR31:=((CLOSE - REF(MA(CLOSE,20),11)) < (0 - 2));

  VAR35:=((VAR18 / (VAR18 + VAR19)) * VAR17);

  VAR36:=((VAR19 / (VAR18 + VAR19)) * VAR17);

  VAR37:=EMA(VAR35,10);

  VAR38:=EMA(VAR36,10);

  VAR39:=EMA(VAR37,10);

  VAR3A:=EMA(VAR38,20);

  VAR3B:=EMA(VAR37,3);

  VAR3C:=EMA(VAR39,6);

  VAR3D:=EMA(VAR3A,2);

  VAR3E:=(VAR3C - VAR3D);

  VAR3F:=(((VAR3C - REF(VAR3C,1)) > 0) AND ((REF(VAR3C,1) - REF(VAR3C,2)) < 0));

  VAR40:=IF((CROSS(VAR3B,VAR3C) AND (VAR3C <= 20)),30,0);

  VAR41:=VAR40;

  VAR42:=(SMA(((AMOUNT / VOL) / 100),13,1) * 1.15);

  VAR43:=(SMA(((AMOUNT / VOL) / 100),13,1) * 0.85);

  VAR44:=(CLOSE - REF(MA(CLOSE,20),11));

  VAR45:=(((((((((((((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43)) OR (((CLOSE < VAR1E) AND VAR31) AND VAR20)) OR ((CLOSE < VAR1E) AND (CLOSE < VAR43))) OR (((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43))) OR (VAR20 AND (CLOSE < VAR2C))) OR ((VAR20 AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (CLOSE < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (CLOSE < VAR43))) OR ((CLOSE < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((CLOSE < VAR1E) AND VAR31));

  VAR4B:=(((HIGH + LOW) + CLOSE) / 3);

  VAR4C:=((VAR4B - MA(VAR4B,14)) / (0.015 * AVEDEV(VAR4B,14)));

  VAR4D:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));

  VAR4E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));

  VAR4F:=(VAR11 AND VAR12);

  VAR50:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)));

  VAR51:=(COUNT(VAR50,1) >= 1);

  VAR52:=(VAR4F AND VAR51);

  VAR53:=(((((VAR20 AND (CLOSE < VAR1E)) AND VAR31) AND (CLOSE < VAR2C)) AND VAR45) AND VAR52);

  VAR5B:=((((((VAR2 >= (0 - 15.8)) AND (VAR2 <= (0 - 12.2))) AND (VAR3 <= (0 - 20.8))) AND (VAR4 <= (0 - 27.5))) AND (VARE <= 11.7)) AND (VAR4C <= (0 - 145)));

  VAR5C:=9.999999884842E+0.26;

  VAR5D:=(COST(10) * 0);

  VAR5E:=((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100));

  VAR5F:=MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5);

  VAR60:=((CROSS((0 - 5),VAR5F) AND (VAR5E < (0 - 0.4))) AND (((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.19)));

  VAR61:=MA(CLOSE,3);

  VAR62:=(REF(CLOSE,2) * 0.865);

  VAR63:=(REF(CLOSE,13) * 0.772);

  VAR64:=MIN(VAR62,VAR63);

  VAR65:=((100 * VOL) / CAPITAL);

  抄底:IF(((((VAR9 OR VAR16) OR VAR53) OR VAR5B) OR ((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8))),80,0),LINETHICK4,COLORRED;

  DRAWTEXT(抄底>0,抄底,'游资买点'),COLOR00C5FF;

  小V逆转:=REF(C,1)REF(C,1) AND C>=REF(C,1)*1.08;

  STICKLINE(小V逆转,20,0,4,0),COLOR000099;

  STICKLINE(小V逆转,30,0,2,0),COLOR0000BB;

  STICKLINE(小V逆转,40,0,1,0),COLOR0000DD;

  STICKLINE(小V逆转,60,0,0.9,0),COLOR0000FF;

  DRAWICON(小V逆转,60,34);

  DRAWTEXT(小V逆转>0,30,'小V逆转'),COLOR00C5FF;

起爆点买入指标

  从源码中可以看出,该指标运用的有抄底、逆转、反向钟摆线、超级拐点等相关知识点的标注与运用技巧,进行分析,投资者可以准确的研判其中的买卖点位置。

  以上就是本文讲解的股市中的起爆点买入指标的源码公式,如果您还想要了解更加专业的技术指标分析,请点击,了解基本的cpI指标应用技巧与操作方法。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top