设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票公式:资金抄底+因资而作指标源码

来源:未知 编辑:admin 时间:2018-03-01
导读: 投资者在进行抄底之前,必须要保证资金仓位的充足,以及本身盈利的操作机会与风险分析,那么为了帮助投资者掌握实战操作技巧,赢家财富网总结了资金抄底+因资而作指标的源码公
 
  投资者在进行抄底之前,必须要保证的充足,以及本身盈利的操作机会与风险分析,那么为了帮助投资者掌握实战操作技巧,赢家财富网总结了资金抄底+因资而作指标的源码公式,以及判断操作机会的要点。 资金抄底股票公式

  ★资金抄底

  结合了日线周期以及相对强弱的大单净量的操作分析,从中判断资金抄底的机会,风险以及盈利机会,具体的源码如下:

  IF(PERIODNAME<>"日线")

  {

  统计:"该指标只在日线周期下有效。";

  RETURN;

  }

  //大单净量

  r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;

  //相对强弱

  LC := REF(CLOSE,1);//前一日收盘价;

  RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;

  RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;

  RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;

  相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;

  wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);

  wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);

  wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);

  短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;

  机会区:20,POINTDOT,colorred;

  风险区:80,POINTDOT,colorgreen;

  风险系数:0.5*相对强弱+0.5*短线波段,coloryellow;

  //买入条件;

  CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;

  CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;

  CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;

  SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);

  X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);

  DRAWICON(X,机会区,"buy");

资金抄底

  从源码中分析,在进行资金抄底的过程中,需要注意短线波段的操作变化,以及出现的风险系数的大小,投资者要及时的做好买卖操作准备,特别是在波段小于20,股价翻红的时候,

  ★★因资而作

  依据资金的进出场以及均线中的压力与支撑的变化进行买卖点的操作分析,做好抄底的准备,以下是具体的操作源码:

  MA5:MA(C,5),COLORF00FF0;

  MA10:MA(C,10),COLORYELLOW;

  MA21:MA(C,21),COLORE66878;

  MA30:MA(C,30),COLORWHITE;

  MA120:MA(C,120),COLOR399C7F,POINTDOT;

  MA240:MA(C,240),COLOR000999,POINTDOT;

  X1:=(C+L+H)/3;

  X2:=EMA(X1,6);

  X3:=EMA(X2,5);

  DRAWICON(CROSS(X2,X3),L*0.98,7);

  DRAWICON(CROSS(X3,X2),H*1.02,8);

  STICKLINE(X2>=X3,LOW,HIGH,0.1,1),COLORRED;

  STICKLINE(X2>=X3,CLOSE,OPEN,2,2),COLORRED;

  STICKLINE(X2>=X3,CLOSE,OPEN,2,8),COLORBROWN;

  STICKLINE(X2

  STICKLINE(X2

  STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2,1),COLORYELLOW;

  STICKLINE(CROSS(X3,X2),OPEN,CLOSE,2,1),COLORBLUE;

  ZLCM:=EMA(WINNER(CLOSE)*70,3);

  SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);

  ZZLKP:=ZLCM/(ZLCM+SHCM)*100;

  ZZLJJ:=EMA(ZZLKP,89);

  ZJLRQD:=ZZLKP-ZZLJJ;

  AA:=EMA(ZJLRQD,3);

  BB:=EMA(AA,5);

  CC:=AA-BB;

  STICKLINE(CC

  STICKLINE(CC>REF(CC,1),CC,0,8,6), COLORRED;

  资金进场:IF(CROSS(AA,BB),5,0),STICK,LINETHICK3,COLORFF00FF;

  资金出场:IF(CROSS(BB,AA),-5,0),STICK,LINETHICK3,COLOR00FF00;

  DRAWICON(资金进场>0,6,1);

  DRAWICON(资金出场<0,-6,2);

  A:=AMOUNT/V/100;VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);

  Y2:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;

  压力:MA(REF(HHV(C,30),1),2);支撑:MA(REF(LLV(C,30),1),2);

  DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;

  DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;

  DRAWTEXT(60*(40*(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)<0

  AND

  COUNT(COUNT(CROSS

  ((EMA(CLOSE,12)-EMA(CLOSE,26)),EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)),BARSLAST

  (EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)>=0))=2,21)=1)

  AND SLOPE(MA(C,5),2)>0) AND

  MA(C,55)>REF(MA(C,55),1) AND

  REF(MA(C,55),1)<=REF(MA(C,55),2),L*0.95,'买入'),COLOR0080FF;

  JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;

  DRAWICON(60*(40*(EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)<0

  AND

  COUNT(COUNT(CROSS

  ((EMA(CLOSE,12)-EMA(CLOSE,26)),EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)),BARSLAST

  (EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9)>=0))=2,21)=1)

  AND SLOPE(MA(C,5),2)>0) AND

  MA(C,55)>REF(MA(C,55),1) AND

  REF(MA(C,55),1)<=REF(MA(C,55),2),LOW,5);

  该指标中主要运用的均线有5日、10日、21日、30日、120日以及240日,从短期均线,中期均线以及长期均线都运用其中,分析个股不同阶段的走势形态,具体的如图国农科技中的走势变化,以及买卖点位置。

因资而作股票指标公式

  以上就是本文通过两则实例讲解的关于资金抄底与因资而作的指标公式应用技巧,如果您还想要了解更多的股市操作技巧,请点击从基本的股票知识进行研究学习,提升股市操作的经验。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top