设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

【股票公式】macd100x指标源码(主图+附图)

来源:未知 编辑:admin 时间:2018-03-01
导读: 不管是在技术指标应用还是股票公式中,我们运用最多的就是macd指标、kdj指标,那么macd100X指标具体的特点与操作方法与macd是否相同,下面通过就通过具体的源码公式以及实际案例进行
 
  不管是在技术指标应用还是中,我们运用最多的就是macd指标、kdj指标,那么macd100X指标具体的特点与操作方法与macd是否相同,下面通过就通过具体的源码公式以及实际案例进行分析。

  【macd100X指标】

  我们知道macd指标在高位或低位是容易出现钝化现象的,同时macd指标的背离形态也是其中的操作要点,所以结合macd100x指标进行其定量结构的分析,主要包含5个要点:

macd100x指标

  1、股价新高或者新低,macd指标中的dif线却没有随之出现新高或者新底的形态,是钝化的形态;

  2、当钝化出现之后,dif的值反向转折,是“结构形成”,此时应该卖出或买入;

  3、Macd的背离,可以隔峰比较;

  4、结构只有在dif上穿或者下穿dea之后才算是100%的形成;

  5、如果dif没有穿dea,但是dif的值反向转折,说明结构形成75%,如果此后dif在穿dea之前再次反向转折,就称作是结构消失;

  具体的操作实例如图通用股份在2016年10月13日的30分钟走势图,在股价的高点位置,出现钝化现象,之后拐头向下,macd100x指标的结构形成,对应的指标线中的走势也是结构形成的状态,由于是顶部形成的结构,出现死叉的卖出信号,投资者可以积极的卖出获利。

通用股份macd100x

  【macd100X源码】

  从底部结构——金叉——死叉——隔峰背离——顶部结构进行源码公式的分析:

  SHORT:=12;

  LONG:=26;

  MID:=9;

  DIF:100*(EMA(CLOSE,SHORT)-EMA(CLOSE,LONG));

  DEA:EMA(DIF,MID);

  MACD:(DIF-DEA)*2,COLORSTICK;

  {底部结构预警}

  死叉:=CROSS(DEA,DIF);

  N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}

  N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}

  N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}

  CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盘价}

  DIFL1:=LLV(DIF,N1+1),NODRAW;

  CL2:=REF(CL1,N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}

  DIFL2:=REF(DIFL1,N1+1),NODRAW;

  CL3:=REF(CL2,N1+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}

  DIFL3:=REF(DIFL2,N1+1),NODRAW;

  PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);

  MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));

  PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);

  MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));

  MDIFB2:=INTPART(DIF/POW(10,PDIFL2));

  MDIFB3:=INTPART(DIF/POW(10,PDIFL3));

  直接底背离:=(CL1MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);

  隔峰底背离:=(CL1MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);

  B:直接底背离 OR 隔峰底背离,NODRAW;

  BG:((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;

  {DRAWTEXT(TFILTER(B,(REF(DIF,1)>REF(DIF,2) AND DIF

  STICKLINE(B,DIF,DEA,1,0),COLORRED;

  DRAWTEXT(TFILTER(BG,C

  {顶部结构预警}

  金叉:=CROSS(DIF,DEA);

  M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}

  M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}

  M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}

  CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盘价}

  DIFH1:=HHV(DIF,M1+1),NODRAW;

  CH2:=REF(CH1,M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}

  DIFH2:=REF(DIFH1,M1+1),NODRAW;

  CH3:=REF(CH2,M1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}

  DIFH3:=REF(DIFH2,M1+1),NODRAW;

  PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);

  MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));

  PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);

  MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));

  MDIFT2:=INTPART(DIF/POW(10,PDIFH2));

  MDIFT3:=INTPART(DIF/POW(10,PDIFH3));

  直接顶背离:=(CH1>CH2 ) AND (MDIFT20 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);

  隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);

  T:直接顶背离 OR 隔峰顶背离,NODRAW;

  TG:((MDIFT2

  {DRAWTEXT(TFILTER(T,(REF(DIF,1)REF(DIF,1)),1),DIFH2,'钝化开始'),COLORYELLOW;}

  STICKLINE(T,DIF,DEA,1,0),COLORGREEN;

  DRAWTEXT(TFILTER(TG,C>REF(CH1,1),1),DIF*1.02,'结构形成'),COLORMAGENTA;

  {举例

  MA5:=MA(C,M);

  MA10:=MA(C,N);

  TIAOJIAN:=CROSS(MA5,MA10);

  NN:=BARSLAST(TIAOJIAN);

  K1:REF(ENTERPRICE,NN);

  NN1:=REF(BARSLAST(TIAOJIAN),NN+1)+NN+1;

  K2:REF(ENTERPRICE,NN1);

  NN2:=REF(BARSLAST(TIAOJIAN),NN1+1)+NN1+1;

  K3:REF(ENTERPRICE,NN2);

  };

  从源码公式中可以看出,不同的顶底结构预示的买卖操作含义是不同的,具体的走势形态如图平安银行中的操作走势。

平安银行

  以上就是本文讲解的关于macd100X指标的相关内容,如果您还想要了解更加专业的技术指标知识,请点击指标进行研究学习,是一种通道型研判趋势的指标。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top