设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票指标公式——bias角度计算+bias画线

来源:未知 编辑:admin 时间:2018-03-01
导读: 在技术指标的应用中,bias指标表示的是乖离率,用来测量股价偏离均线大小程度的指标,应用的范围也比较广泛,那么在实战中,bias的角度以及画线是怎样的,下面赢家财富网通过bi
 
  在技术指标的应用中,bias指标表示的是乖离率,用来测量股价偏离均线大小程度的指标,应用的范围也比较广泛,那么在实战中,bias的角度以及画线是怎样的,下面赢家财富网通过bias角度计算以及bias画线的进行源码解析:

  【bias角度计算】

  Bias角度计算通过大盘的走势以及强势转折等形态进行分析,具体的公式源码如下:

  N1:=5;N2:=10;N3:=20;

  BIAS1:=(CLOSE-MA(CLOSE,N1))/MA(CLOSE,N1)*100,LINETHICK1;

  BIAS2:=(CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100,LINETHICK2;

  BIAS3:=(CLOSE-MA(CLOSE,N3))/MA(CLOSE,N3)*100,LINETHICK4;

  MAXBIAS1:=IF(BIAS1>REF(BIAS1,1),BIAS1,0);

  角度计算1:IF(BIAS1>REF(BIAS1,1),(MAXBIAS1-MIN(BIAS1,REF(BIAS1,1)))/

  (ABS(BIAS1)+ABS(REF(BIAS1,1))),0),LINETHICK1;

  MAXBIAS2:=IF(BIAS2>REF(BIAS2,1),BIAS2,0);

  角度计算2:IF(BIAS2>REF(BIAS2,1),(MAXBIAS2-MIN(BIAS2,REF(BIAS2,1)))/

  (ABS(BIAS2)+ABS(REF(BIAS2,1))),0),LINETHICK1;

  MAXBIAS3:=IF(BIAS3>REF(BIAS3,1),BIAS3,0);

  角度计算3:IF(BIAS3>REF(BIAS3,1),(MAXBIAS3-MIN(BIAS3,REF(BIAS3,1)))/

  (ABS(BIAS3)+ABS(REF(BIAS3,1))),0),LINETHICK1;

  三强:=角度计算1>=1 AND 角度计算2>=1 AND 角度计算3>=1;

  STICKLINE(三强,0.5,1,0.5,0),COLORRED;

  大盘6日:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6)*100;

  大盘12日:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12)*100;

  大盘24日:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24)*100;

  大盘:=(大盘6日 + 大盘12日 + 大盘24日)/3;

  个股6日:=(C-MA(C,6))/MA(C,6)*100;

  个股12日:=(C-MA(C,12))/MA(C,12)*100;

  个股24日:=(C-MA(C,24))/MA(C,24)*100;

  个股:=(个股6日 + 个股12日 + 个股24日)/3;

  强势出击:=(大盘>REF(大盘,1) AND CROSS(个股,大盘));

  STICKLINE(强势出击,0,1,0,0),COLORRED;

  转折1:=REF(角度计算1,2)>REF(角度计算1,1) AND REF(角度计算1,1)<角度计算1

  AND REF(角度计算1,2)<角度计算1;

  转折2:=REF(角度计算2,2)>REF(角度计算2,1) AND REF(角度计算2,1)<角度计算2

  AND REF(角度计算2,2)<角度计算2;

  转折3:=REF(角度计算3,2)>REF(角度计算3,1) AND REF(角度计算3,1)<角度计算3

  AND REF(角度计算3,2)<角度计算3;

  同时转折买点:=转折1 AND 转折2 AND 转折3;

  DRAWICON(同时转折买点 AND C>MA(C,5)

  AND MA(C,5)>REF(MA(C,5),1)

  AND REF(MA(C,5),1)>REF(MA(C,5),2),

  MIN(MIN(角度计算1,角度计算2),角度计算3),1);

  DRAWICON(同时转折买点,角度计算1,1);

  DRAWICON(同时转折买点,角度计算2,1);

  DRAWICON(同时转折买点,角度计算3,1);

  金屋顶:1,CIRCLEDOT,LINETHICK3,COLORRED;

  从源码中进行分析,通过3个角度计算大盘以及个股的走势强弱,同时经过转折买卖点进行顶部和底部的研判,具体的走势如图深桑达A的日K线走势,从底部的7.70元向上拉升,在13.09元的点位阶段性见顶,形成金屋顶的走势,投资者要注意高位投资风险,及时卖出获利。

BIAS角度计算

  【bias画线】

  Bias主要是通过趋势线的走势以及指标线的偏离程度,进行买入点的确定,具体的源码公式如下:

  N:=12;

  B:(CLOSE-MA(CLOSE,N))/MA(CLOSE,N)*100;

  M:=INTPART(2*N/4);

  A1:=REF(B,M)=HHV(B,2*M+1);

  B1:=FILTER(A1,M);

  C1:=BACKSET(B1,M+1);

  D1:=FILTER(C1,M);

  R3:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S1:=R3>REF(R3,1);

  DRAWLINE(D1,B,S1,B,1),COLORRED;

  M1:=INTPART(3*N/7);

  A120:=REF(B,M1)=HHV(B,2*M1+1);

  B120:=FILTER(A120,M1);

  C321:=BACKSET(B120,M1+1);

  D119:=FILTER(C321,M1);

  R1:=BACKSET(ISLASTBAR,BARSLAST(D119)+1); S10:=R1>REF(R1,1);

  DRAWLINE(D119,B,S10,B,1),COLORYELLOW;

  M2:=INTPART(1*N/10);

  A2:=REF(B,M2)=HHV(B,2*M2+1);

  B2:=FILTER(A2,M2);

  C2:=BACKSET(B2,M2+1);

  D2:=FILTER(C2,M2);

  R4:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); S2:=R4>REF(R4,1);

  DRAWLINE(D2,B,S2,B,1),COLORBLUE;

  如图恒顺醋业(600305)的股价走势,从12.12元开始拉升,上下震荡,并且经历了横盘的调整走势形态,在bias线突破下降趋势线的点位时,提示买入的操作信号,同时股价开始启动拉升,投资者可以积极的买入,等待后市的上涨获利拉升。

bias画线公式

  以上就是本文讲解的关于bias角度计算以及bias画线的指标公式源码,如果您还想要了解更加专业的技术形态分析,请点击,了解基本的持仓问题。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top