设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

“龙宫顶底”+“尖顶针”主图指标公式详解

来源:未知 编辑:admin 时间:2018-03-01
导读: 股价上涨的顶部以及下跌的底部都是投资者比较关注的要点,因为投资者的惯用操作策略就是高抛低吸,那么在赢家财富网股票指标公式栏目就为您介绍一种“龙宫顶底”与“尖顶针”
 
  股价上涨的顶部以及下跌的底部都是投资者比较关注的要点,因为投资者的惯用操作策略就是高抛低吸,那么在赢家财富网股票指标公式栏目就为您介绍一种“龙宫顶底”与“尖顶针”的技术指标进行股价K线走势的顶底研判,下面通过具体的源码公式与实战案例进行分析:

  【龙宫顶底】

  适合于短线、中线、中长线以及长线的操作范围,通过顶底的研判,捕捉反弹以及操作的最佳机会,具体的源码公式如下:

  VAR1:=MA(CLOSE,27);

  VAR2:=(CLOSE-VAR1)/VAR1*100;

  RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

  RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;

  RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;

  VARA:=MA(VAR2,2);

  VARB:=BARSLAST(CROSS(-10,VARA)=1);

  VARC:=BARSLAST(CROSS(VARA,10)=1);

  VARD:=VARA<-10 AND VARB>3;

  VARE:=VARA>10 AND VARC>3;

  短线:SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00;

  中线:SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED;

  中长线:=-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40));

  长线:SMA(RSV3,5,1),COLORYELLOW;

  看底:STICKLINE(中线<15,中线,15,6,0),COLORF00FF0;

  黄金:STICKLINE(短线<20 AND 中线<20 AND 长线<20,MAX(长线,MAX(短线,中线)),20,3,0),COLOR00CCFF;

  看顶:STICKLINE(中线>80,80,中线,3,0),COLORFFF000;

  DRAWICON(CROSS(长线,15),中线,1);

  DRAWTEXT(LONGCROSS(中线,20,15),20,'反弹');

  DRAWTEXT(CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,1)OR CROSS(长线,5),20,'绝佳机会'),COLORYELLOW;

  底:DRAWTEXT(CROSS(中长线,-90) AND (长线<中线 AND 长线>REF(长线,1)OR 短线<20 AND 中线<20 AND 长线 <20),长线,'底'),COLORFF00FF;

  DR:=IF(COUNT(CROSS(中长线,-90),12)=3,30,5);

  KH1:=IF(VARD,VARA,0);

  KH2:=REF(KH1,1)<0;

  龙宫藏宝:短线<20 AND 中线<20 AND 长线<20;

  天宫藏宝:中线>80 AND 中线>80 AND 长线>80;

  触底:CROSS(中长线,-90) AND (长线<中线 AND 长线>REF(长线,1)OR 短线<20 AND 中线<20 AND 长线 <20);

  反弹:LONGCROSS(中线,20,15) OR CROSS(长线,15);

  绝佳机会:CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,1)OR CROSS(长线,5),COLORYELLOW;

  如图全新好的股价K线走势,从最低点15.50元开始拉升上涨,到28.65元见顶,在龙宫顶底指标中都有不同颜色区域的标注,投资者可以在底部积极的介入,在顶部进行卖出获利。

  

龙宫顶底

 

  【尖顶针】

  通过不同通道的走势变化,提示买卖点的位置,并进行持股分析,具体的源码公式:

  VAR1:=1;

  VAR2:=REF(CLOSE-OPEN, 2);

  VAR3:=REF(CLOSE, 1);

  VAR4:=REF(CLOSE, 2);

  VAR5:=REF(CLOSE, 3);

  VAR6:=REF(CLOSE, 4);

  VAR7:=MAX(MAX(MAX(CLOSE, VAR3), VAR4), VAR5);

  VAR8:=MIN(MIN(MIN(CLOSE, VAR3), VAR4), VAR5);

  {红持股:STICKLINE(CLOSE=VAR7 AND (VAR3>=VAR4 OR VAR3>=VAR5) OR VAR3=VAR7 AND (VAR4=VAR8 OR VAR5=VAR8) AND CLOSE>=VAR4 OR VAR4=VAR7 AND VAR5=VAR8 AND CLOSE>=VAR3 OR VAR5=VAR7 AND CLOSE>=VAR3 AND CLOSE>=VAR4, VAR3, CLOSE, 5, 1), COLORRED;}

  {品红变盘:STICKLINE(CLOSE=VAR7 AND VAR3=VAR8, VAR4, CLOSE, 5, 1), COLORMAGENTA;}

  {黄下跌:STICKLINE(CLOSE=VAR8 AND (VAR3

  {绿买:STICKLINE(VAR3=VAR7 AND CLOSE=VAR8, VAR4, CLOSE, 5, 0), COLORGREEN;}

  {STICKLINE(VAR3=VAR8 AND CLOSE>=VAR4 OR (VAR4=VAR8 AND VAR3<=VAR5 OR VAR5=VAR8 AND VAR3<=VAR4) AND VAR4=VAR3, VAR3, VAR4, 5, 0), COLORGREEN;}

  蓝卖:STICKLINE(VAR3=VAR7 AND CLOSEVAR5 OR VAR5=VAR7 AND VAR3>VAR4) AND VAR4>=VAR6 AND CLOSE

  VAR9:=SAR(5, 1, 5);

  VAR10:=EMA(CLOSE, 30);

  VAR11:=IF(CLOSE>450, 8, IF(CLOSE>=20 AND CLOSE<150, 0.200, IF(CLOSE<20 AND CLOSE>=10, 0.070, IF(CLOSE<10, 0.030, 0.070))));

  {变色龙:STICKLINE(CLOSE>VAR9, VAR10, VAR10+VAR11, 6, 0), COLORMAGENTA;}

  STICKLINE(CLOSE

  STICKLINE(CROSS(CLOSE, VAR9), VAR10, VAR10-VAR11, 6, 0);

  STICKLINE(CROSS(VAR9, CLOSE), VAR10, VAR10+VAR11, 6, 0), COLORFF0066;

  STICKLINE(RANGE(DAY, 6, 9) OR RANGE(DAY, 27, 30), VAR10+0.010, VAR10-0.010, 6, 0), COLORYELLOW;

  VAR22:=MA(LLV(CLOSE,9)*1.1,14)*1;

  VAR33:=MA(HHV(CLOSE,26)*0.9,14)*1;

  VAR55:=EMA((HIGH+LOW+CLOSE)/3,3);

  VARB:=AMOUNT/(100*VOL);

  VARC:=MA(VARB,34);

  VARD:=MA(CLOSE,26);

  通道: (VARD+VARC)/2, POINTDOT, COLORYELLOW;

  阻力: VARD+2*STD(CLOSE,34),LINETHICK2 , COLORGREEN;

  支持: (VARD-2*STD(CLOSE,26)),LINETHICK2 , COLORGREEN;

  VARE:=MA(WINNER(CLOSE),34)*100;

  警: DRAWTEXT(VARE>60 AND HIGH>阻力,HIGH,'★警'), COLORYELLOW;

  突破:DRAWTEXT(VARE<15 AND CROSS(VAR55,通道),LOW,'★突破'), COLORAAAAAA;

  MA5:MA(C,5);

  BB5:=MA5-REF(MA5,1);

  MA10:MA(C,10);

  BB10:=MA10-REF(MA10,1);

  MA20:=EMA(C,20);

  A1:=FILTER(MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5

  A2:=(2*C+H+L+O)/5;

  A3:=LLV(L,5);

  A4:=HHV(H,4);

  A5:=EMA((A2-A3)/(A4-A3)*100,4);

  A6:=EMA(0.667*REF(A5,1)+0.333*A5,2);

  A7:=EMA(A2,13)-EMA(A2,34);

  A8:=EMA(A7,5); A9:=(-2)*(A7-A8)*3.8;

  DRAWTEXT(CROSS(A5,A6)AND A1<40,L-0.08,' 买'),COLORYELLOW;

  DRAWTEXT(CROSS(A9,MA(A9,3))AND(A7>A8),H+0.08,' 卖'),COLORGREEN;

  依据源码进行分析,当翻红的时候继续持股,黄色是下跌的信号,此外还要分析阻力与支撑的变化,具体的实战案例,如图平安银行的走势形态,从8.52元开始拉升,在9.80元阶段见顶,是卖出的信号,要及时的卖出获利。

  

尖顶针

 

  本文通过两则实例讲解了股市中捕捉顶底的龙宫顶底指标与尖顶针指标的主图公式源码,如果您还想要了解更加专业的技术形态分析,请点击梯量柱选股公式,进行选股知识的相关学习和了解。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top