设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票技术指标公式——轮回线主图解说

来源:未知 编辑:admin 时间:2018-03-01
导读: 自然讲究的是循环往复,而人有生老病死的人生轮回,同样的在股市中也是有轮回的,不同的是在股市中,可以用轮回线的指标公式进行源码表示,并展现在K线图中的走势形态,下面赢
 
  自然讲究的是循环往复,而人有生老病死的人生轮回,同样的在股市中也是有轮回的,不同的是在股市中,可以用轮回线的指标公式进行源码表示,并展现在K线图中的走势形态,下面赢家财富网就通过基本的股票公式源码进行实例分析:

  【轮回线】

  IS1T1:=1;

  IS2T1:=1;

  IS1T2:=1;

  ISPX:=0;

  ISGOLD:=1;

  ISVOL:=0;

  DFIX:=0;

  DFIXX:=IF(DFIX=0, IF(PERIOD=0,17,IF(PERIOD=1 OR PERIOD=2,10,IF(PERIOD=3,7,IF(PERIOD>=4,5,1)))),DFIX);

  轮回DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);

  轮回DEA:= EMA(轮回DIFF,9);

  上穿周期:=BARSLAST(LONGCROSS(轮回DEA,0,DFIXX));

  下穿周期:=BARSLAST(LONGCROSS(0,轮回DEA,DFIXX));

  最低点周期:=BARSLAST(L=LLV(L,下穿周期) AND 轮回DEA<0);

  最高点周期:=BARSLAST(H=HHV(H,最低点周期));

  轮高点TJ1:=LONGCROSS(0,轮回DEA,DFIXX);{最后一天的条件}

  轮高点TJ2:=BACKSET(轮高点TJ1,最高点周期+1);

  轮高点:=轮高点TJ2>REF(轮高点TJ2,1);

  轮低最高点周期:=BARSLAST(H=HHV(H,上穿周期) AND 轮回DEA>0);

  轮低最低点周期:=BARSLAST(L=LLV(L,轮低最高点周期));

  轮低点TJ1:=LONGCROSS(轮回DEA,0,DFIXX);{最后一天的条件}

  轮低点TJ2:=BACKSET(轮低点TJ1,轮低最低点周期+1);

  轮低点:=轮低点TJ2>REF(轮低点TJ2,1);

  GGP:=BARSLAST(轮高点);

  DDP:=BARSLAST(轮低点);

  距离:=IF(轮高点,DDP,IF(轮低点,GGP,DRAWNULL)),NODRAW;

  力度:=IF(轮高点,(HHV(H,GGP+1)-LLV(L,DDP+1)),IF(轮低点,(HHV(H,GGP+1)-LLV(L,DDP+1)),DRAWNULL)),NODRAW;

  均力:=IF(轮高点,(HHV(H,GGP+1)-LLV(L,DDP+1))/(DDP),IF(轮低点,(HHV(H,GGP+1)-LLV(L,DDP+1))/(GGP),DRAWNULL)),NODRAW;

  轮回点:=轮低点 OR 轮高点;

  NZ1:=BARSLAST(轮回点);{最近转折点到现在的时间,如果现在是轮回点,值为0}

  NZ2:=REF(NZ1,NZ1+1)+NZ1+1;{第二转折点到现在的时间};

  NZ3:=REF(NZ2,NZ2)+NZ2;{第3转折点到现在的时间}

  NZ4:=REF(NZ2,NZ3)+NZ3;{第4转折点到现在的时间}

  纠偏率:=IF(轮回点,力度/REF(力度,NZ2),DRAWNULL)NODRAW;

  盘背率:=IF(轮回点,力度/REF(力度,NZ3),DRAWNULL)NODRAW;

  {画线}

轮回线

  ISLINE:=BACKSET(轮高点 OR 轮低点,MAX(GGP,DDP));

  LED:=IF(GGP>DDP,REF(L,DDP)+REF(均力,(DDP))*(DDP),REF(H,GGP)-REF(均力,(GGP))*(GGP));

  LED2:=IF(GGP>DDP,REF(L,DDP)+REF(均力,(DDP))*2*(DDP),REF(H,GGP)-REF(均力,(GGP))*2*(GGP));

  LED3:=IF(GGP>DDP,REF(L,DDP)+REF(均力,(DDP))/2*(DDP),REF(H,GGP)-REF(均力,(GGP))/2*(GGP));

  角11:DRAWLINE(IS1T1 AND (轮低点 OR 轮高点) AND ISLINE,IF(GGP>DDP,L,H),ISLASTBAR,LED,0),COLORWHITE,DOTLINE;

  角21:DRAWLINE(IS2T1 AND (轮低点 OR 轮高点) AND ISLINE,IF(GGP>DDP,L,H),ISLASTBAR,LED2,0),COLORLIBLUE,DOTLINE;

  角12:DRAWLINE(IS1T2 AND (轮低点 OR 轮高点) AND ISLINE,IF(GGP>DDP,L,H),ISLASTBAR,LED3,0),COLORLIGREEN,DOTLINE;

  上升:DRAWLINE(轮低点,L,轮高点, H,0),COLORMAGENTA;

  下降:DRAWLINE(轮高点,H,轮低点, L,0),COLORGREEN;

  {轮回点要标出当下斜率,命名斜率1,分轮高点和轮低点两种情况}

  最后轮回点TJ:=BACKSET(ISLASTBAR,BARSLAST(轮回点)+1);

  最后轮回点:=最后轮回点TJ>REF(最后轮回点TJ,1);

  最后轮回点SJ:=BARSLAST(最后轮回点);

  BS:=IF (CLOSE>1000,1,100);

  {轮低点情况}

  轮低点斜率1:=IF(轮低点,(REF(H,NZ2)-L)/NZ2,0) ;

  轮低点斜率2:=IF(轮低点,(REF(H,NZ2)-REF(L,NZ3))/(NZ3-NZ2),0);

  轮低点斜率3:=IF(轮低点,(REF(H,NZ4)-REF(L,NZ3))/(NZ4-NZ3),0);

  DRAWNUMBER(轮低点,(L+(REF(H,NZ2)-L)*0.1),BS*(REF(H,NZ2)-L)),COLORYELLOW; {显示轮回线空间}

  DRAWNUMBER(轮低点,L,BS*((REF(H,NZ2)-L)/NZ2)),COLORYELLOW; {波动率}

  {轮高点情况}

  轮高点斜率1:=IF(轮高点,(H-REF(L,NZ2))/NZ2,0);

  轮高点斜率2:=IF(轮高点,(REF(H,NZ3)-REF(L,NZ2))/(NZ3-NZ2),0);

  轮高点斜率3:=IF(轮高点,(REF(H,NZ3)-REF(L,NZ4))/(NZ4-NZ3),0);

  DRAWNUMBER(轮高点,H,BS*(H-REF(L,NZ2))) COLORYELLOW ; {显示轮回线空间}

  DRAWNUMBER(轮高点,H-(H-REF(L,NZ2))*0.1,BS*((H-REF(L,NZ2))/NZ2)) COLORYELLOW ; {波动率}

  VPOINT:=IF(轮低点,L,IF(轮高点,H,0));

  轮回周期:=NZ2;

  下降力度:=IF(轮低点,1,0)*(REF(H,NZ2)-L);

  下降波动率:=IF(轮低点,1,0)*((REF(H,NZ2)-L)/NZ2);

  上升力度:=IF(轮高点,1,0)*(H-REF(L,NZ2));

  上升波动率:=IF(轮高点,1,0)*((H-REF(L,NZ2))/NZ2);

  PTOP:=BARSLAST(轮高点);

  PBOT:=BARSLAST(轮低点);

  P1:=BARSLAST(下降波动率>0);

  P2:=SUMBARS(下降波动率>0,2);

  LLP:=BARSLAST(L=LLV(L,PTOP));

  HHP:=BARSLAST(H=HHV(H,PBOT));

  虚波动率:IF(PTOP

  虚拟空间:=IF(PTOP

  P11:=BARSLAST(上升波动率>0);

  P22:=SUMBARS(上升波动率>0,2);

  DOWN:=REF(下降波动率,P1),NODRAW;

  UP:=REF(上升波动率,P11),NODRAW;

  VLINE:=IF (PTOP>PBOT,REF(上升力度,P11),(-1)*REF(下降力度,P1)) ,NODRAW;

  LINE:=IF(PTOP>PBOT,(LLV(L,P1+1)+VLINE),HHV(H,P11+1)+VLINE),NODRAW;

  {STICKLINE(IF(PTOP>PBOT,REF(下降波动率,P1)

  DD0:=BARSLAST(轮回点),NODRAW;

  DD1:=SUMBARS(轮回点,2)-1,NODRAW;

  DD2:=SUMBARS(轮回点,3)-1,NODRAW;

  DD3:=SUMBARS(轮回点,4)-1,NODRAW;

  BD0:=IF(REF(上升波动率*BS,DD0)>0,REF(上升波动率*BS,DD0),REF(下降波动率*BS,DD0));

  BD1:=IF(REF(上升波动率*BS,DD1)>0,REF(上升波动率*BS,DD1),REF(下降波动率*BS,DD1));

  BD2:=IF(REF(上升波动率*BS,DD2)>0,REF(上升波动率*BS,DD2),REF(下降波动率*BS,DD2));

  BD3:=IF(REF(上升波动率*BS,DD3)>0,REF(上升波动率*BS,DD3),REF(下降波动率*BS,DD3));

  HH0:=IF(REF(下降力度,DD0)>0,REF(下降力度,DD0),REF(上升力度,DD0)),NODRAW;

  HH1:=IF(REF(下降力度,DD1)>0,REF(下降力度,DD1),REF(上升力度,DD1)),NODRAW;

  HH2:=IF(REF(下降力度,DD2)>0,REF(下降力度,DD2),REF(上升力度,DD2)),NODRAW;

  HH3:=IF(REF(下降力度,DD3)>0,REF(下降力度,DD3),REF(上升力度,DD3)),NODRAW;

  CC0:=REF(轮回周期,DD0),NODRAW;

  CC1:=REF(轮回周期,DD1),NODRAW;

  CC2:=REF(轮回周期,DD2),NODRAW;

  CC3:=REF(轮回周期,DD3),NODRAW;

  累计换手:SUM(VOL/CAPITAL,DD0-1)*(IF(PTOP

  跌幅:(HHV(H,DD0)-LLV(L,DD0))/LLV(L,DD0)*100*(IF(PTOP

  空间平衡:HH0+HH2-HH1-HH3,NODRAW;

  时间平衡:CC0+CC2-CC1-CC3,COLORYELLOW,NODRAW;

  空间预测:HH1+虚拟空间-HH0-HH2,NODRAW;

  时间预测:CC1+DD0-CC0-CC2,COLORYELLOW,NODRAW;

  {JIAODUSUM:540-(ATAN(BD0)+2*(ATAN(BD1)+ATAN(BD2)+ATAN(BD3))-ATAN(BD4))*180/3.14159;}

  PHV:=IF(PERIOD=0,0.05,IF(PERIOD=1 OR PERIOD=2,0.1,IF(PERIOD=3,0.2,IF(PERIOD=4,0.3,1))));

  四方平衡:=ABS(HH0+HH2-HH1-HH3)/C

  {DRAWICON(四方平衡 AND 轮回点 AND L=REF(L,DD0),L,17);}

  PHLINE:=IF(PTOP>PBOT,REF(VPOINT,DD0)-(HH1-HH0-HH2),REF(VPOINT,DD0)+(HH1-HH0-HH2));

  STICKLINE(1,PHLINE,PHLINE,10,0),COLORYELLOW;{平衡线画图}

  失衡:IF(PTOP

  {DRAWNUMBER(轮低点,L,180-(ATAN(HH0/DD0)*180/3.14159+ATAN(HH1/DD1)*180/3.14159)),COLORYELLOW; 夹角}

  {DRAWNUMBER(轮高点,H,180-(ATAN(HH0/DD0)*180/3.14159+ATAN(HH1/DD1)*180/3.14159)) COLORYELLOW ; 夹角}

  {PLINE:=IF(BP

  STICKLINE(CURRBARSCOUNT

  {2560}

  ISDAY:=IF (PERIOD=5,1,DRAWNULL);

  MA5:ISDAY*MA(CLOSE,5)COLORYELLOW,NODRAW;

  MA10:ISDAY*MA(CLOSE,10),NODRAW;

  {MA25:MA(CLOSE,25),LINETHICK2,COLORMAGENTA;}

  {IF(MA25

  MA60:MA(CLOSE,60),NODRAW;

  MA120:MA(CLOSE,120),NODRAW;

  MA250:MA(CLOSE,250),NODRAW;

  PP1:=H>=MA(C,5)*(100+8)/100;

  PP2:=L*(100+20)/100<=MA(C,25);

  DRAWICON(PP1 AND PERIOD=5,H*1.02,15);{逃跑}

  {DRAWICON(PP2,L*0.97,26);{钻石底}

  DRAWICON((MA(C,4)*4+MA(C,25))/5>=MA(C,25) AND MA(C,5)

  {下行中的轮回角度线的画法}

  最后低点TJ:=BACKSET(ISLASTBAR,BARSLAST(轮低点)+1);

  最后低点:=最后低点TJ>REF(最后低点TJ,1);

  最后低点2天:=IF(REF(最后低点,1),1,0);

  最后低点SJ:=BARSLAST(最后低点);

  相距SJ:=最后低点SJ-最后轮回点SJ;

  {DRAWLINE(IS1T1 AND 最后低点,L,最后轮回点,REF(L,相距SJ)+REF(轮低点斜率1,相距SJ)*相距SJ,0) COLORWHITE DOTLINE;

  DRAWLINE(IS2T1 AND 最后低点,L,最后轮回点,REF(L,相距SJ)+REF(轮低点斜率1,相距SJ)*相距SJ*2,0) COLORLIBLUE DOTLINE;

  DRAWLINE(IS1T2 AND 最后低点,L,最后轮回点,REF(L,相距SJ)+REF(轮低点斜率1,相距SJ)*相距SJ*0.5,0) COLORLIGREEN DOTLINE;

  }

  {上行中的轮回角度线的画法}

  最后高点TJ:=BACKSET(ISLASTBAR,BARSLAST(轮高点)+1);

  最后高点:=最后高点TJ>REF(最后高点TJ,1);

  最后高点2天:=IF(REF(最后高点,1),1,0);

  最后高点SJ:=BARSLAST(最后高点);

  {DRAWLINE(IS1T1 AND 最后高点,H,最后高点2天,REF(H,1)-REF(轮高点斜率1,1),1) COLORWHITE DOTLINE;

  DRAWLINE(IS2T1 AND 最后高点,H,最后高点2天,REF(H,1)-REF(轮高点斜率1,1)*2,1) COLORLIBLUE DOTLINE;

  DRAWLINE(IS1T2 AND 最后高点,H,最后高点2天,REF(H,1)-REF(轮高点斜率1,1)/2,1) COLORLIGREEN DOTLINE;

  }

  {画比较线}

  DRAWLINE(ISPX AND 最后低点 AND 最后低点SJ=最后轮回点SJ,L,最后低点2天,REF(L,1)+REF(轮低点斜率2,1),1) COLORYELLOW;

  DRAWLINE(ISPX AND 最后高点 AND 最后高点SJ=最后轮回点SJ,H,最后高点2天,REF(H,1)-REF(轮高点斜率2,1),1) COLORYELLOW;

  {黄金线}

  {黄金柱&黄金线}

  倍量TJ:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1));

  回调量:=IF(C>=O,0,VOL);

  黄金线TJ:=倍量TJ>=1.9 AND 倍量TJ<=3 AND REFX(C,1)>O AND REFX(C,2)>O AND REFX(C,3)>O AND REFX(回调量,1)/VOL<1 AND REFX(回调量,2)/VOL<1 AND REFX(回调量,3)/VOL<1;

  黄金线WZ:=MIN(MIN(REFX(C,1),REFX(C,2)),REFX(C,3));

  黄金线XS:=IF (黄金线WZ>=C,O,黄金线WZ);

  STICKLINE(ISVOL AND 黄金线TJ AND C>O,O,C,2,0),COLORYELLOW;

  DRAWLINE(ISVOL AND 黄金线TJ AND C>O,黄金线WZ,REF(黄金线TJ AND C>O,15),REF(黄金线WZ,15),0),COLORYELLOW,DOTLINE;

  DRAWNUMBER(ISVOL AND 黄金线TJ AND C>O,黄金线WZ,黄金线WZ),COLORYELLOW;

  {画空间黄金分割线}

  {轮低点划线}

  最后点TJ:=BACKSET(ISLASTBAR,BARSLAST(轮低点 OR 轮高点)+1);

  最后点:=最后点TJ>REF(最后点TJ,1);

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L, REF(轮低点,7),REF(L,7),0),COLORLIGRAY,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.191,L+(REF(H,NZ2)-L)*0.191),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.191, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*0.191,7),0),COLORGRAY,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.382,L+(REF(H,NZ2)-L)*0.382),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.382, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*0.382,7),0),COLORLIBLUE,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.5,L+(REF(H,NZ2)-L)*0.5),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.5, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*0.5,7),0),COLORLIGREEN,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.618,L+(REF(H,NZ2)-L)*0.618),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.618, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*0.618,7),0),COLORLICYAN,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.809,L+(REF(H,NZ2)-L)*0.809),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*0.809, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*0.809,7),0),COLORLIRED,DOTLINE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L), REF(轮低点,7),REF(L+(REF(H,NZ2)-L),7),0),COLORLIMAGENTA,DOTLINE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*1.191, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*1.191,7),0),COLORLIBLUE,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*1.191,L+(REF(H,NZ2)-L)*1.191),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*1.618, REF(轮低点,7),REF(L+(REF(H,NZ2)-L)*1.618,7),0),COLORBLUE,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮低点,L+(REF(H,NZ2)-L)*1.618,L+(REF(H,NZ2)-L)*1.618),COLORWHITE;

  {轮高点划线}

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H, REF(轮高点,15),REF(H,15),0),COLORLIMAGENTA,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.191,H-(H-REF(L,NZ2))*0.191),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.191, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*0.191,15),0),COLORLIRED,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.382,H-(H-REF(L,NZ2))*0.382),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.382, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*0.382,15),0),COLORLICYAN,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.5,H-(H-REF(L,NZ2))*0.5),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.5, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*0.5,15),0),COLORLIGREEN,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.618,H-(H-REF(L,NZ2))*0.618),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.618, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*0.618,15),0),COLORLIBLUE,DOTLINE;

  DRAWNUMBER(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.809,H-(H-REF(L,NZ2))*0.809),COLORWHITE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*0.809, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*0.809,15),0),COLORGRAY,DOTLINE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2)), REF(轮高点,15),REF(H-(H-REF(L,NZ2)),15),0),COLORLIGRAY,DOTLINE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*1.191, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*1.191,15),0),COLORLIBLUE,DOTLINE;

  DRAWLINE(ISGOLD AND 最后点 AND 轮高点,H-(H-REF(L,NZ2))*1.618, REF(轮高点,15),REF(H-(H-REF(L,NZ2))*1.618,15),0),COLORBLUE,DOTLINE;

  STICKLINE((C-REF(C,1))/REF(C,1)>0.05,MAX(O,C)-(ABS(O-C))/3,MAX(O,C)-ABS(O-C)*2/3,2.5,0),COLORYELLOW;

  STICKLINE((C-REF(C,1))/REF(C,1)>0.095,MAX(O,C)-(ABS(O-C))/3,MAX(O,C)-ABS(O-C)*2/3,2.5,0),COLORMAGENTA;

  STICKLINE((C-REF(C,1))/REF(C,1)<-0.05,MAX(O,C)-(ABS(O-C))/3,MAX(O,C)-ABS(O-C)*2/3,2.5,0),COLORBLUE;

  STICKLINE((C-REF(C,1))/REF(C,1)<-0.095,MAX(O,C)-(ABS(O-C))/3,MAX(O,C)-ABS(O-C)*2/3,2.5,0),COLORGREEN;

  DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,HYBLOCK),COLORYELLOW;

  DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,DYBLOCK),COLORYELLOW;

  DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,GNBLOCK),COLORYELLOW;

  DRAWTEXT_FIX(ISLASTBAR,0.1,0.1,0,EXTERNSTR(0,1))COLORYELLOW;

  ISWEEK:=IF (PERIOD=6,1,DRAWNULL);

  MA181:ISWEEK*MA(C,181),COLORMAGENTA;

  立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);

  雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);

  惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);

  春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);

  清明:=FILTER(MONTH=4 AND (DAY=4 OR DAY=6 ),2);

  谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);

  立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);

  小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);

  芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);

  夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);

  小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);

  大署:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);

  立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);

  处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);

  白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);

  秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);

  寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);

  霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);

  立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);

  小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);

  大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);

  冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);

  小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);

  大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);

  DRAWTEXT(ISDAY*立春,HIGH*1.02,'立春'),COLORGREEN;

  DRAWTEXT(ISDAY*雨水,HIGH*1.02,'雨水'),COLORGREEN;

  DRAWTEXT(ISDAY*惊蛰,HIGH*1.02,'惊蛰'),COLORGREEN;

  DRAWTEXT(ISDAY*春分,HIGH*1.02,'春分'),COLORGREEN;

  DRAWTEXT(ISDAY*清明,HIGH*1.02,'清明'),COLORGREEN;

  DRAWTEXT(ISDAY*谷雨,HIGH*1.02,'谷雨'),COLORGREEN;

  DRAWTEXT(ISDAY*立夏,HIGH*1.02,'立夏'),COLORMAGENTA;

  DRAWTEXT(ISDAY*小满,HIGH*1.02,'小满'),COLORMAGENTA;

  DRAWTEXT(ISDAY*芒种,HIGH*1.02,'芒种'),COLORMAGENTA;

  DRAWTEXT(ISDAY*夏至,HIGH*1.02,'夏至'),COLORMAGENTA;

  DRAWTEXT(ISDAY*小暑,HIGH*1.02,'小暑'),COLORMAGENTA;

  DRAWTEXT(ISDAY*大署,HIGH*1.02,'大署'),COLORMAGENTA;

  DRAWTEXT(ISDAY*立秋,HIGH*1.02,'立秋'),COLORYELLOW;

  DRAWTEXT(ISDAY*处暑,HIGH*1.02,'处暑'),COLORYELLOW;

  DRAWTEXT(ISDAY*白露,HIGH*1.02,'白露'),COLORYELLOW;

  DRAWTEXT(ISDAY*秋分,HIGH*1.02,'秋分'),COLORYELLOW;

  DRAWTEXT(ISDAY*寒露,HIGH*1.02,'寒露'),COLORYELLOW;

  DRAWTEXT(ISDAY*霜降,HIGH*1.02,'霜降'),COLORYELLOW;

  DRAWTEXT(ISDAY*立冬,HIGH*1.02,'立冬'),COLORWHITE;

  DRAWTEXT(ISDAY*小雪,HIGH*1.02,'小雪'),COLORWHITE;

  DRAWTEXT(ISDAY*大雪,HIGH*1.02,'大雪'),COLORWHITE;

  DRAWTEXT(ISDAY*冬至,HIGH*1.02,'冬至'),COLORWHITE;

  DRAWTEXT(ISDAY*小寒,HIGH*1.02,'小寒'),COLORWHITE;

  DRAWTEXT(ISDAY*大寒,HIGH*1.02,'大寒'),COLORWHITE;

  (OPEN+CLOSE)/2;

平安银行轮回线

  从基本的源码公式中可以发现,轮回线包含的有不同周期的高点与低点,上涨下跌斜率以及波动率的关系变化,时间与空间的平衡关系,最重要的案例分析如图:平安银行的走势变化,结合24节气的变化,以及空间和时间的平衡做好时间预测,以及走势操作分析,希望投资者能够把握好操作机会。

  如果您还想要了解更加专业的轮回线指标分析或者应用技巧操作,请点击股票技术指标公式


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top