设为首页 - 加入收藏
广告 1000x90
您的当前位置:主页 > 股票知识 > 股票炒股技巧 > 正文

定量结构股票技术指标公式解析(附源码)

来源:未知 编辑:admin 时间:2018-03-01
导读: 分析股市K线形态的变化,最讲究的就是量、价、时、空的因素,而股市的四大因素综合起来的操作就是“定量结构”,只有清楚的了解股价变化的定量结构,才能够更好的捕捉个股的买
 
  分析股市K线形态的变化,最讲究的就是量、价、时、空的因素,而股市的四大因素综合起来的操作就是“定量结构”,只有清楚的了解股价变化的定量结构,才能够更好的捕捉个股的买卖点,那么接下来我们就通过其具体的源码进行分析。

  【定量结构】

  其实,定量结构是依据macd指标的两条线进行研究扩展的,具体的使用方法包含3个方面:

  1、股价出线新高或者新低的时候,macd指标中的dif并没有创出新高或新低,称做是钝化;

  2、当钝化出现之后,dif的值反向转折,称为“结构形成”,是买入和卖出的点位;

  3、Dif值在和前高或前低比较时,按照前极值的数量级,比较前两位数字进行分析。

  具体的源码公式如下:

  DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26));

  DEA:EMA(DIF,9);

  MACD:(DIF-DEA)*2,COLORSTICK;

  死叉:=CROSS(DEA,DIF);

  N1:=BARSLAST(死叉);

  N2:=REF(BARSLAST(死叉),N1+1);

  N3:=REF(BARSLAST(死叉),N2+N1+2);

  CL1:=LLV(C,N1+1);

  DIFL1:=LLV(DIF,N1+1);

  CL2:=REF(CL1,N1+1);

  DIFL2:=REF(DIFL1,N1+1);

  CL3:=REF(CL2,N1+1);

  DIFL3:=REF(DIFL2,N1+1);

  PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);

  MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));

  PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);

  MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));

  MDIFB2:=INTPART(DIF/POW(10,PDIFL2));

  MDIFB3:=INTPART(DIF/POW(10,PDIFL3));

  直接底背离:=(CL1MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);

  隔峰底背离:=(CL1MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);

  B:=(直接底背离 OR 隔峰底背离);

  BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));

  底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);

  STICKLINE(B OR BG,DIF,DEA,8,0),colorred;

  DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'钝化'),coloryellow;

  DRAWTEXT(FILTER(BG,10),(DIF*1.5),'结构形成'),colormagenta;

  DRAWTEXT(FILTER(底背离消失,10),(DIF+MACD),'消失'),colorgreen;

  STICKLINE(BG,0,(DIF+DEA),5,0), colorred;

  金叉:=CROSS(DIF,DEA);

  M1:=BARSLAST(金叉);

  M2:=REF(BARSLAST(金叉),M1+1);

  M3:=REF(BARSLAST(金叉),M2+M1+2);

  CH1:=HHV(C,M1+1);

  DIFH1:=HHV(DIF,M1+1);

  CH2:=REF(CH1,M1+1);

  DIFH2:=REF(DIFH1,M1+1);

  CH3:=REF(CH2,M1+1);

  DIFH3:=REF(DIFH2,M1+1);

  PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);

  MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));

  PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);

  MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));

  MDIFT2:=INTPART(DIF/POW(10,PDIFH2));

  MDIFT3:=INTPART(DIF/POW(10,PDIFH3));

  直接顶背离:=(CH1>CH2 ) AND (MDIFT20 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);

  隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);

  T:=(直接顶背离 OR 隔峰顶背离);

  TG:=((MDIFT2

  顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);

  STICKLINE(TG,0,(DIF+DEA),5,0), colorgreen;

  STICKLINE(T OR TG,DIF,DEA,8,0),colorgreen;

  DRAWTEXT(FILTER(TG,20),(DIF*1.4),'结构形成'),colormagenta;

  DRAWTEXT(FILTER(顶背离消失,20),(DIF+MACD),'消失'),colorgreen;

  从以上的源码公式中能够发现,该指标应用了顶底背离,直接底背离、隔峰底背离、金叉死叉进行研究分析,如图美丽生态的个股日K线走势,股价从9.47元开始下跌到6.4元的低价,macd线经历了消失、钝化的循环过程,在6.40元的位置结构形成,是买入点的位置。

美丽生态

  本文通过一则实例讲解了“定量结构”股票指标的实战应用方法以及源码公式,如果您还想要了解更加专业的技术形态,请点击:。


相关推荐:

网友评论:

发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top