设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票公式——波段+融轨(数字)+筹码堆积

来源:未知 编辑:admin 时间:2018-03-01
导读: 股市交易涉及的方面是比较多的,首先要判定股价的运行趋势,其次是主力成本的变化,然后是价格变化以及买卖点分析,那么结合波段技巧与筹码分布如何研究个股的走势行情呢,下
 
  股市交易涉及的方面是比较多的,首先要判定股价的运行趋势,其次是主力成本的变化,然后是价格变化以及买卖点分析,那么结合波段技巧与筹码分布如何研究个股的走势行情呢,下面我们就通过波段+数字+筹码堆积的进行源码解析。 波段股票公式

  【融轨】

  首先通过融轨的通道走势运行,研判个股的趋势发展,具体的源码如下:

  c1:=C;

  N:=10;

  LB:=COST(1);

  HB:=COST(99);

  W:=(HB-LB)/10;

  N0:=LB;

  N1:=LB+W;

  N2:=LB+2*W;

  N3:=LB+3*W;

  N4:=LB+4*W;

  N5:=LB+5*W;

  N6:=LB+6*W;

  N7:=LB+7*W;

  N8:=LB+8*W;

  N9:=LB+9*W;

  N10:=HB;

  A0:=WINNER(N1)*100-WINNER(N0)*100;

  A1:=WINNER(N2)*100-WINNER(N1)*100;

  A2:=WINNER(N3)*100-WINNER(N2)*100;

  A3:=WINNER(N4)*100-WINNER(N3)*100;

  A4:=WINNER(N5)*100-WINNER(N4)*100;

  A5:=WINNER(N6)*100-WINNER(N5)*100;

  A6:=WINNER(N7)*100-WINNER(N6)*100;

  A7:=WINNER(N8)*100-WINNER(N7)*100;

  A8:=WINNER(N9)*100-WINNER(N8)*100;

  A9:=WINNER(N10)*100-WINNER(N9)*100;

  xa0:DRAWSL(BARSTATUS=2 and A0>0,(N1+N0)/2,0,N*A0,1),Color262626,LINETHICK4;

  xa1:DRAWSL(BARSTATUS=2 and A1>0,(N2+N1)/2,0,N*A1,1),Color262626,LINETHICK4;

  xa2:DRAWSL(BARSTATUS=2 and A2>0,(N3+N2)/2,0,N*A2,1),Color262626,LINETHICK4;

  xa3:DRAWSL(BARSTATUS=2 and A3>0,(N4+N3)/2,0,N*A3,1),Color262626,LINETHICK4;

  xa4:DRawsl(BARSTATUS=2 and A4>0,(N5+N4)/2,0,N*A4,1),Color262626,LINETHICK4;

  xa5:DRAWSL(BARSTATUS=2 and A5>0,(N6+N5)/2,0,N*A5,1),Color262626,LINETHICK4;

  xa6:DRAWSL(BARSTATUS=2 and A6>0,(N7+N6)/2,0,N*A6,1),Color262626,LINETHICK4;

  xa7:DRAWSL(BARSTATUS=2 and A7>0,(N8+N7)/2,0,N*A7,1),Color262626,LINETHICK4;

  xa8:DRAWSL(BARSTATUS=2 and A8>0,(N9+N8)/2,0,N*A8,1),Color262626,LINETHICK4;

  xa9:DRAWSL(BARSTATUS=2 and A9>0,(N10+N9)/2,0,N*A9,1),Color262626,LINETHICK4;

  {K线颜色}

  STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),Color0088FF;

  STICKLINE(CLOSE

  {融胜轨道}

  AA:=MA((2*CLOSE+HIGH+LOW)/4,5);

  通1:=AA*102/100;

  通2:=AA*(200-102)/100;

  ZZ:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

  DD:=DMA(CLOSE,ZZ);

  上:=(1+7/100)*DD;

  下:=(1-7/100)*DD;

  中:=(上+下)/2;

  顶:=(1+14/100)*DD;

  底:=(1-14/100)*DD;

  轨道角度1:=(ATAN((MA(底,5)/REF(MA(底,5),1)-1)*100)*180/3.14115926),LINETHICK0;

  五日角度1:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926),LINETHICK0;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C>顶,L,'顶 '+NUMTOSTR(顶[SYSPARAM(1)],2)),pxdn27,Color0088FF;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C<顶,L,'顶 '+NUMTOSTR(顶[SYSPARAM(1)],2)),pxdn27,COLOR666600;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C>上,L,'上 '+NUMTOSTR(上[SYSPARAM(1)],2)),pxdn52,Color0088FF;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C<上,L,'上 '+NUMTOSTR(上[SYSPARAM(1)],2)),pxdn52,COLOR666600;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C>中,L,'中 '+NUMTOSTR(中[SYSPARAM(1)],2)),pxdn77,Color0088FF;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C<中,L,'中 '+NUMTOSTR(中[SYSPARAM(1)],2)),pxdn77,COLOR666600;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C>下,L,'下 '+NUMTOSTR(下[SYSPARAM(1)],2)),pxdn102,Color0088FF;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C<下,L,'下 '+NUMTOSTR(下[SYSPARAM(1)],2)),pxdn102,COLOR666600;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C>底,L,'底 '+NUMTOSTR(底[SYSPARAM(1)],2)),pxdn127,Color0088FF;

  DRAWTEXT(SYSPARAM(1)=BARPOS and C<底,L,'底 '+NUMTOSTR(底[SYSPARAM(1)],2)),pxdn127,COLOR666600;

  {DRAWTEXT(SYSPARAM(1)=BARPOS and 上,上,'上'+NUMTOSTR(上[SYSPARAM(1)],2)),pxup8,colorwhite;

  DRAWTEXT(SYSPARAM(1)=BARPOS and 中,中,'中'+NUMTOSTR(中[SYSPARAM(1)],2)),pxup8,colorYellow;

  DRAWTEXT(SYSPARAM(1)=BARPOS and 下,下,'下'+NUMTOSTR(下[SYSPARAM(1)],2)),pxup8,colorwhite;

  DRAWTEXT(SYSPARAM(1)=BARPOS and 底,底,'底'+NUMTOSTR(底[SYSPARAM(1)],2)),pxup8,colorgreen;}

  ZH:=HHV(H,22);ZHH:=H;

  ZGF1:=ZHH/1.0809;ZGF2:=ZHH/1.1618;

  ZGF3:=ZHH/1.0809/1.1618;ZGF4:=ZHH/1.1618/1.1618;

  DRAWTEXTEX(c,1,10,650,'第一回调区:'+NUMTOSTR(ZGF1[SYSPARAM(1)],2)+'--'+NUMTOSTR(ZGF2[SYSPARAM(1)],2)+''),Color00FF00;

  DRAWTEXTEX(c,1,10,700,'第二回调区:'+NUMTOSTR(ZGF3[SYSPARAM(1)],2)+'--'+NUMTOSTR(ZGF4[SYSPARAM(1)],2)+''),Color00FF00;

  ZL:=LLV(L,22);ZLL:=L;

  ZGFB1:=ZLL*1.0809;ZGFB2:=ZLL*1.1618;ZGFB3:=ZLL*1.0809*1.1618;ZGFB4:=ZLL*1.1618*1.1618;

  DRAWTEXTEX(c,1,10,450,'第一压力区:'+NUMTOSTR(ZGFB1[SYSPARAM(1)],2)+''+'--'+NUMTOSTR(ZGFB2[SYSPARAM(1)],2)+''),Color00EEFF;

  DRAWTEXTEX(c,1,10,500,'第二压力区:'+NUMTOSTR(ZGFB3[SYSPARAM(1)],2)+''+'--'+NUMTOSTR(ZGFB4[SYSPARAM(1)],2)+''),Color00EEFF;

  DRAWTEXTEX(c,1,10,400,'本次起动价:'+NUMTOSTR(ZL[SYSPARAM(1)],2)+''),Color00EEFF;

  DRAWTEXTEX(c,1,10,600,'预计回调价:'+NUMTOSTR(ZH[SYSPARAM(1)],2)+''),color00DD00;

  DRAWTEXTEX(c,1,10,50,'收 益: '+ NUMTOSTR(FINANCE(33),2)+' 元'),ColorFFB060;

  DRAWTEXTEX(c,1,120,50,'净资产: '+NUMTOSTR(FINANCE(34),2 )+' 元'),ColorFFB060;

  DRAWTEXTEX(c,1,10,100,'流通股:'+ NUMTOSTR(FINANCE(7)/10000,2)+' 亿'),ColorFFB060;

  DRAWTEXTEX(c,1,120,100,'占总股本:'+NUMTOSTR(FINANCE(7)/FINANCE(1)*100 ,2)+' %'),ColorFFB060;

  DRAWTEXTEX(c,1,10,150,'负债率:'+ NUMTOSTR(FINANCE(11)/FINANCE(15),2)),ColorFFB060;

  DRAWTEXTEX(c,1,120,150,'主营收入:'+NUMTOSTR(FINANCE(20)/10000,1 )+''),ColorFFB060;

  {DRAWTEXTEX(c,1,10,250,STRLEFT(BLKNAME,90)),Color00FFFF;}

  DRAWTEXTEX(c,1,10,200,'主题投资:'+SELFSTRING('主题投资')),ColorFFB060;

  DRAWTEXTEX(c,1,10,0,'善谋者,谋势;不善者,谋子'),Color0088FF;

  通过上下中轨道对顶底进行研判,确定主题投资的个股趋势以及目标股的变化。然后选择一个波段进行操作,具体的波段运行趋势源码如下:

筹码堆积

  【波段主图】

  input:KG1(20,1,50);

  input:F1(10,1,20);

  input:P(10,1,20);

  D3X3:ma(c,3),SHIFT3,COLORMAGENTA;

  KG:=IF(DATATYPE<=1,1,IF(DATATYPE<=3,5,IF(DATATYPE<=5,10,KG1)));

  F:=IF(DATATYPE<=3,1,IF(DATATYPE=4,3,IF(DATATYPE=5,5,F1)));

  ZX:=ZIG(4,KG);

  CCH:=PEAK(4,KG,1);

  CCY:=TROUGH(4,KG,1);

  CC:IF(ZX

  W1:=CROSS(CCH-0.02,ZX);

  W2:=CROSS(ZX,CCY+0.02);

  FD:=F/100;

  YS:=IF(ZX

  W:=IF(ZX

  H1:REF(CC*(1-YS*1),BARSLAST(W)),LINETHICK0;

  H2:REF(CC*(1-YS*2),BARSLAST(W)),LINETHICK0;

  H3:REF(CC*(1-YS*3),BARSLAST(W)),LINETHICK0;

  H4:REF(CC*(1-YS*4),BARSLAST(W)),LINETHICK0;

  H5:REF(CC*(1-YS*5),BARSLAST(W)),LINETHICK0;

  H6:REF(CC*(1-YS*6),BARSLAST(W)),LINETHICK0;

  H7:REF(CC*(1-YS*7),BARSLAST(W)),LINETHICK0;

  H8:REF(CC*(1-YS*8),BARSLAST(W)),LINETHICK0;

  H9:REF(CC*(1-YS*9),BARSLAST(W)),LINETHICK0;

  H10:REF(CC*(1-YS*10),BARSLAST(W)),LINETHICK0;

  H11:REF(CC*(1-YS*11),BARSLAST(W)),LINETHICK0;

  H12:REF(CC*(1-YS*12),BARSLAST(W)),LINETHICK0;

  H13:REF(CC*(1-YS*13),BARSLAST(W)),LINETHICK0;

  H14:REF(CC*(1-YS*14),BARSLAST(W)),LINETHICK0;

  H15:REF(CC*(1-YS*15),BARSLAST(W)),LINETHICK0;

  HHD:=SYSPARAM(4);

  LLD:=SYSPARAM(5);

  系数:=IF(DATATYPE=2,1.00005,IF(DATATYPE<6,1.0005,1.002));

  STICKLINE(CC>=LLD AND CC<=HHD,CC,CC*系数,20,0),colorFF;

  STICKLINE(CC>=LLD AND CC<=HHD,H1,H1,5,0),colorA0A0A0;

  STICKLINE(H1>LLD AND H1

  STICKLINE(H2>LLD AND H2

  STICKLINE(H3>LLD AND H3

  STICKLINE(H4>LLD AND H4

  STICKLINE(H5>LLD AND H5

  STICKLINE(H6>LLD AND H6

  STICKLINE(H7>LLD AND H7

  STICKLINE(H8>LLD AND H8

  STICKLINE(H9>LLD AND H9

  STICKLINE(H10>LLD AND H10

  STICKLINE(H11>LLD AND H11

  STICKLINE(H12>LLD AND H12

  STICKLINE(H13>LLD AND H13

  STICKLINE(H14>LLD AND H14

  DRAWTEXT(W AND CC>=LLD AND CC<=HHD,H1,''+NUMTOSTR(F*1,0)+'%'),PXDN5,colorA0A0A0;

  DRAWTEXT(W AND H1>LLD AND H1

  DRAWTEXT(W AND H2>LLD AND H2

  DRAWTEXT(W AND H3>LLD AND H3

  DRAWTEXT(W AND H4>LLD AND H4

  DRAWTEXT(W AND H5>LLD AND H5

  DRAWTEXT(W AND H6>LLD AND H6

  DRAWTEXT(W AND H7>LLD AND H7

  DRAWTEXT(W AND H8>LLD AND H8

  DRAWTEXT(W AND H9>LLD AND H9

  DRAWTEXT(W AND H10>LLD AND H10

  DRAWTEXT(W AND H11>LLD AND H11

  DRAWTEXT(W AND H12>LLD AND H12

  DRAWTEXT(W AND H13>LLD AND H13

  DRAWTEXT(W AND H14>LLD AND H14

  AK1:=BARSLAST(W1)+1;

  BK1:=BARSLAST(W2)+1;

  目前:=IF(BK1>AK1,AK1,BK1);

  DRAWNUMBER(W1,CC,REF(目前,1),0),ALIGN2,PXUP30,colorFF00FF;

  DRAWNUMBER(W2,CC,REF(目前,1),0),ALIGN2,PXDN10,colorFF00;

  方向:=IF(CC=CCH,'下行 ','上升 ');

  周期:=IF(DATATYPE=6,'天 ',IF(DATATYPE=7,'周 ',IF(DATATYPE=8,'月 ','单位')));

  DRAWTEXTEX(CC=CCH,1,320,0,'目前波段'+方向+NUMTOSTR(目前,0)+周期),COLOR666600;

  DRAWTEXTEX(CC<>CCH,1,320,0,'目前波段'+方向+NUMTOSTR(目前,0)+周期),Color0088FF;

  DRAWTEXT(W1,CC,''+周期),PXUP30,colorFF00FF;

  DRAWTEXT(W2,CC,''+周期),PXDN10,colorFF00;

  {p:10,1,30}

  X1:=TROUGH(4,P,1);

  X8:=TROUGHBARS(4,P,1)=0;

  X11:=TROUGHBARS(4,P,2);

  X18:=TROUGHBARS(4,P,1);

  X13:=TROUGHBARS(4,P,1);

  X3:=PEAK(4,P,1);

  X31:=PEAKBARS(4,P,2);

  X38:=PEAKBARS(4,P,1);

  X33:=PEAKBARS(4,P,1);

  X5:=PEAKBARS(4,P,1)=0;

  光标位置:=SYSPARAM(1);

  CLDIS:=X13[SYSPARAM(1)];

  CHDIS:=X33[SYSPARAM(1)];

  TCL:=光标位置-CLDIS;

  TCH:=光标位置-CHDIS;

  BLDIS:=X18[SYSPARAM(1)];

  BHDIS:=X38[SYSPARAM(1)];

  TBL:=光标位置-BLDIS;

  TBH:=光标位置-BHDIS;

  ALDIS:=X11[SYSPARAM(1)];

  AHDIS:=X31[SYSPARAM(1)];

  TAL:=光标位置-ALDIS;

  TAH:=光标位置-AHDIS;

  K一浪A:=IF(TCL>TCH,TAL,TAH);

  K二浪B:=IF(TCL>TCH,TBH,TBL);

  K三浪C:=IF(TCL>TCH,TCL,TCH);

  PH:=HIGH;

  PL:=LOW;

  P一浪A:IF(TCL>TCH,PL[TAL+0],PH[TAH+0]),LINETHICK0;

  P二浪B:IF(TCL>TCH,PH[TBH+0],PL[TBL+0]),LINETHICK0;

  P三浪C:IF(TCL>TCH,PL[TCL+0],PH[TCH+0]),LINETHICK0;

  DRAWLINE(BARPOS=K一浪A,P一浪A,BARPOS=K二浪B,P二浪B,0),LINEDOT,color77FFFF;

  DRAWLINE(BARPOS=K二浪B,P二浪B,BARPOS=K三浪C,P三浪C,0),LINEDOT,color77FFFF;

  一浪长:=P二浪B-P一浪A;

  Y1:=一浪长;

  P1:=P三浪C+Y1;

  VERTLINE(BARPOS=K三浪C),LINEDOT,colorFFFF;

  DRAWTEXT(BARPOS=K三浪C,SYSPARAM(4)*0.95,'转\n \n\n折\n \n点'),colorFFFF;

  Y0618:=一浪长*0.618;

  P0618:=P三浪C+Y0618;

  PARTLINE(BARPOS>K三浪C,P0618),colorCCFF;

  DRAWTEXT(BARPOS=K三浪C,P0618,' '+NUMTOSTR(P0618,3)+' cop'),colorCCFF;

  Y1000:=一浪长*1;

  P1000:=P三浪C+Y1000;

  PARTLINE(BARPOS>K三浪C,P1000),colorCCFF;

  DRAWTEXT(BARPOS=K三浪C,P1000,' '+NUMTOSTR(P1000,3)+' op'),colorCCFF;

  Y1618:=一浪长*1.618;

  P1618:=P三浪C+Y1618;

  PARTLINE(BARPOS>K三浪C,P1618),colorCCFF;

  DRAWTEXT(BARPOS=K三浪C,P1618,' '+NUMTOSTR(P1618,3)+' xop'),colorCCFF;

  DK:=MA(CLOSE,7);

  {STICKLINE(DK<=CLOSE AND CLOSE>=OPEN,HIGH,LOW,0.1,1),colorFF;

  STICKLINE(DK<=CLOSE AND CLOSE>=OPEN,CLOSE,OPEN,8,1),colorFF;

  STICKLINE(DK<=CLOSE AND CLOSE

  STICKLINE(DK<=CLOSE AND CLOSE

  STICKLINE(DK>CLOSE AND CLOSE>=OPEN,HIGH,LOW,0.1,1),colorFF00;

  STICKLINE(DK>CLOSE AND CLOSE>=OPEN,CLOSE,OPEN,8,1),colorFF00;

  STICKLINE(DK>CLOSE AND CLOSE

  STICKLINE(DK>CLOSE AND CLOSE

  当前月:=FRACPART(ROUND(CURRENTDATE/100)/100)*100;

  月:=MONTH;

  日:=DAY;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='1',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(小寒)、6、15、20(大寒)、21、*25\n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='2',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:4(立春)、6、15、18(雨水)21\n \n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='3',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(惊蛰)、6、15、*20(春分)、21\n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='4',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:4(清明)、6、15、20(谷雨)21\n \n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='5',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(立夏)、6、*12、15、21(小满)\n \n \n \n \n'),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='6',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:5(芒种)、6、*14、21(夏至)\n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='7',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(小暑)、8、15、*19、23(大暑)\n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='8',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:*6、7(立秋)、8、18、23(处暑)\n \n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='9',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(白露)、8、15、*18、23(秋分)\n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='10',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:8(寒露)、15、23(霜降)、*31\n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='11',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(立冬)、8、15、22(小雪)23、*28\n \n \n \n \n \n '),ALIGN5,colorFFFF;

  DRAWTEXT(SYSPARAM(2)=BARPOS AND NUMTOSTR(当前月,0)='12',CLOSE,NUMTOSTR(当前月,0)+'月时间之窗:7(大雪)、8、15、22(冬至)23、*31\n \n \n \n \n \n '),ALIGN5,colorFFFF;

  将波浪与时间窗的变化结合在一起进行研究分析,具体的案例如图平安银行在2013年2月19日的走势变化,其波段下行了6天,收益以及流通股,负债率等等都在图中显示,希望投资者能够把握其中的回调价格与回调区域的变化,进行买卖操作。

平安银行

  以上就是本文讲解的关注股市中波段与筹码趋势运行的形态分析以及源码公式,如果您还想要了解更加专业的技术分析知识,请点击:。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top