设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票指标公式实战分析量比走势与涨跌变化

来源:未知 编辑:admin 时间:2018-03-01
导读: 量比指标是股票证券软件中的一种指标工具,通常用来分析个股的走势以及股价涨跌情况,而对于量比指标具体的源码公式是如何编译的,我们可以从日线量比、量比走势、量比涨跌三
 
  量比指标是中的一种指标工具,通常用来分析个股的走势以及股价涨跌情况,而对于量比指标具体的源码公式是如何编译的,我们可以从日线量比、量比走势、量比涨跌三个方面进行研究,接下来赢家财富网就通过具体股票指标公式源码与实战案例进行分析。

  1、日线量比

  指的是股价走势当天日线的量比比那话,可以用日量比和分时量比进行对比分析:

  TT:=IF(HOUR>12,(HOUR-13)*60+MINUTE+120,(HOUR-9)*60+MINUTE-30);

  P:=IF(PERIOD=5,FROMOPEN,TT);

  TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));

  MTIME:=MOD(FROMOPEN,TOTAL);

  CTIME:=IF(MTIME<0.5,TOTAL,MTIME);

  VVOL:=IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,VOL),NODRAW;

  S1:=IF(PERIOD=4,60,IF(PERIOD=3,30,IF(PERIOD=2,15,IF(PERIOD=1,5,1))));

  S2:=IF(PERIOD=5,4,IF(PERIOD=4,8,IF(PERIOD=3,16,IF(PERIOD=2,48,240))));

  S3:=P/S1,NODRAW;

  分时量比:=SUM(VOL,S3)/S3/DYNAINFO(16)/TOTAL;

  日量比:=VVOL/REF(MA(VOL,5),1);

  量比:IF(PERIOD<5,分时量比,IF(PERIOD=5,日量比,0));

  结合源码分析实战中的操作案例,如图平安银行从8.93元向上连续拉升到9.80元的日K线走势图,其量比指标的走势是随着股价上涨下跌而变化的,目前对应的量比值是在0.8。

平安银行日线量比

  2、量比走势

  量比走势的变化是通过数据天数、即时虚拟量进行即时量比的研究分析,其具体的如下:

  数据天数:BARSSINCE(CLOSE>0)+1,NODRAW;

  即时虚拟量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL/FROMOPEN*240,DRAWNULL),NODRAW;

  虚拟量:=IF(CURRBARSCOUNT>1,VOL,即时虚拟量);

  即时量比:虚拟量/REF(MA(虚拟量,5),1),COLORWHITE,LINETHICK2;

  STICKLINE(C>=O,即时量比*0.99,0,0,0),COLORRED;

  STICKLINE(C

  {DRAWTEXT(即时量比>1.5 AND 即时量比<1.8,即时量比*1.1,'放量'),COLORYELLOW;}

  DRAWNUMBER(即时量比>=1.5 AND 即时量比<1.8,即时量比*1.11,即时量比);

  {DRAWTEXT(即时量比>=1.8 AND 即时量比<3,即时量比*1.11,'倍量'),COLORYELLOW;}

  DRAWNUMBER(即时量比>=1.8 AND 即时量比<3,即时量比*1.15,即时量比);

  {DRAWTEXT(即时量比>=3 AND 即时量比<5,即时量比*1.12,'大量'),COLORYELLOW;}

  DRAWNUMBER(即时量比>=3 AND 即时量比<5,即时量比*1.2,即时量比),COLORYELLOW;

  DRAWTEXT(即时量比>=5 ,即时量比*1.115,'巨量'),COLORYELLOW;

  IF(即时量比>10,即时量比,DRAWNULL),COLORBLUE,LINETHICK2;

  IF(即时量比<10 AND 即时量比>2.5,即时量比,DRAWNULL),COLORRED,LINETHICK2;

  IF(即时量比<1 ,即时量比,DRAWNULL),COLORGREEN,LINETHICK2;

  IF(即时量比<0.5 ,即时量比,DRAWNULL),COLORBLUE,LINETHICK2;

  1;

  然而不同的数据天数,其量比走势是会发生变化的,如图深振业A的股价日K线运行趋势,从7.16元上涨到10.95元,拉升将近3个点,对应的量比走势是上下震荡的走势,其中在股价对应的低点位置,持续爱你了两次巨量的波的形态,是投资者可以考虑介入的点位,其中数据天数是420天,即时虚拟量在71254.00,对应的即时量比则是0.69。

深振业A量比走势

  3、量比涨跌

  股价的涨跌与量比涨跌变化是一致的,主要运行的是量比、涨跌、角度、换手,四个方面进行股价买卖位置的提示分析,具体的操作源码如下:

  VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

  获利盘: WINNER(CLOSE)*100;

  VAR33:=SMA(VAR22,3,1);

  VAR44:=SMA(VAR33,9,1);

  VAR55:=3*VAR33-2*VAR44;

  VAR66:=VOL;

  量比: VOL/MA(VOL,5);

  涨跌: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

  角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

  换手: VOL/CAPITAL*100;

  VAR77:=SUM(换手,30);

  VAR88:=LLV(INDEXL,5);

  VAR99:=HHV(INDEXH,5);

  VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);

  VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);

  VARCC:=MA(VARBB,30);

  VARDD:=EMA(获利盘,4);

  本盘亿股: CAPITAL/1000000,;

  V5: MA(VOL,5)*2;

  VARE:=MA(V5,3);

  V34: MA(VOL,34)*2;

  VARF:=(涨跌>VARDD AND 角度<-30 AND 涨跌>3);

  CROSS(VARBB,VARCC) AND VARCC<29;

  CROSS(VARCC,VARBB) AND VARCC>58;

  STICKLINE(VOL AND VAR33>VAR44,0,VOL,3,1),COLORRED;

  STICKLINE(VOL AND VAR33<=VAR44,0,VOL,3,1),COLORCYAN;

  DRAWTEXT(CROSS(VARBB,VARCC) AND 角度<-18 AND VARCC<29,VOL*1.2,'买 '),COLORYELLOW;

  W:DRAWTEXT(CROSS(VARCC,VARBB) AND VARCC>58,VOL*1.2,'卖'),COLORWHITE;

  DRAWTEXT(CROSS(VARE,V5) AND 角度>22,V5,'<----');

  VAR2:=CLOSE-REF(CLOSE,1);

  VAR3:=IF(CLOSE-REF(CLOSE,1)>=0,VAR2,0);

  VAR4:=REF(CLOSE,1)-CLOSE;

  VAR5:=IF(CLOSE-REF(CLOSE,1)<=0,VAR4,0);

  VAR6:=SUM(VAR3,16)/SUM(VAR5,16);

  VAR7:=100-100/(1+VAR6);

  VAR8:=EMA(VAR7,16);

  VAR9:=EMA(VAR8,8);

  VARA:=EMA(VAR8,45);

  MO:=(VAR8-VARA);

  ML:=(VAR9-VARA);

  VAR1A:=EMA(CLOSE,32);

  如图平安银行的日K线图,从8.52元上涨拉升到9.80元的价格,对应的量比是向上拉升的,此时的获利盘在44.30,涨跌幅度为0.66,并且提示了相应的卖出点,希望投资者能够及时把握操作机会。

平安银行量比涨跌

  本文通过三个方面讲解了量比指标的源码公式,如果您还想要了解更加专业的技术指标知识,请点击:。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top