设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

满江红指标公式源码及其实战应用解析

来源:未知 编辑:admin 时间:2018-03-01
导读: 股票投资过程中股民们免不了要分析k线,所以k线组合在实战中应用很多,它对股民们炒股非同寻常。对满江红主图指标公式源码还不是特别熟悉,同样对该指标公式的实战应用也不是很
 

  股票投资过程中股民们免不了要分析k线,所以在实战中应用很多,它对股民们炒股非同寻常。尤其是k线底部组合中的满江红,相信大家都接触过。但对满江红主图指标公式源码还不是特别熟悉,同样对该指标公式的实战应用也不是很熟练。今天赢家财富网主编就来和大家分享一下相关知识

满江红指标公式

  【满江红指标公式源码】

  B1:=MA(C,1);

  B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);

  SMA2:=MA(B2,3);

  停损下限:IF(LLV(MA(B2,8),3)

  IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;

  IF(B2

  SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;

  VAR1A:=(2*CLOSE+HIGH+LOW)/4;

  VAR2A:=MA(VAR1A,7);

  VAR3A:=VAR2A-MA(VAR1A,7/2)<0;

  VAR4A:=VAR2A-MA(VAR1A,7/2)>0;

  VAR5A:=BARSLAST(VAR3A);

  VAR6A:=0-BARSLAST(VAR4A);

  VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);

  STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,0),COLORBLUE;

  STICKLINE(SNAKEA>SMA2 AND B2

  VAR11A:=(CLOSE*2+HIGH+LOW)/4;

  VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);

  VAR31A:=EMA(VAR21A,5);

  {STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;

  STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;

  STICKLINE((C

  STICKLINE((C

  STICKLINE((C

  STICKLINE((C

  STICKLINE((C>O),CLOSE,OPEN,2,0),COLOR0754E9;

  STICKLINE((C>O),CLOSE,OPEN,1.5,0),COLOR076EF3;

  STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR077BF3;}

  VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));

  VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));

  VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));

  VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));

  VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);

  {STICKLINE(VAR1B,O,O+(C-O)/3,3,0),COLOR10D0FF;}

  STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;

  STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;

  AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);

  {STICKLINE(AA,O,O+(C-O)/3,3,0),COLOR00DD00;}

  STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;

  STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;

  A13:=EMA(CLOSE,55);

  A14:=MA(CLOSE,75);

  A15:=EMA(A14,3);

  A16:=EMA(A15,3);

  A17:=(HIGH + LOW) / 5;

  A18:=(MA(A17,4)) - (MA(A17,34));

  A19:=CROSS(A18,0);

  A20:=CROSS(0,A18);

  A21:=BARSLAST(A19);

  A22:=BARSLAST(A20);

  A23:=REF(A19,1);

  A24:=REF(A20,1);

  A25:=BARSLAST(A23);

  A26:=BARSLAST(A24);

  A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));

  A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);

  A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);

  A30:=A28 AND ((COUNT(A28,A21)) = 1);

  A31:=A29 AND ((COUNT(A29,A22)) = 1);

  A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));

  A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));

  DRAWTEXT(A32,SMA2*0.99,'←═买入'),COLORYELLOW;

  AC:=AMOUNT/(VOL);

  YY:=MA(AC,13);

  LLL:=(C-YY)/YY*100;

  MIDC := MA(CLOSE,22);

  UPPERC:= MIDC + 2*STD(C,22);

  LOWERC:= MIDC - 2*STD(C,22);

  BBA:=(C-LOWERC)/(UPPERC-LOWERC);

  BBC:=FORCAST(BBA,3);

  LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));

  {//STICKLINE(LIFENGCYC,BBC,0.5,6,0);}

  {//BBD:(UPPER+LOWER)/2*(C-UPPER);}

  STICKLINE(LIFENGCYC>0,C,O,2,0),COLOR10ABFF;

  {STICKLINE(LIFENGCYC>0,C,O,1.5,0),COLOR10D0FF;

  STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10FFFF;}

  DRAWTEXT(LIFENGCYC>0,LOW*0.99,'☆'),COLORDD00DD;

  【实战应用】

鸿博股份

  满江红k线组合模型是一种买入信号,由一组k线窄幅震荡堆叠形成,在该模型中含有主力低位吸筹信号,投资者可逢低建仓,持股一段时间后,会有获利空间。如下图所示中的鸿博股份(002229),该股在2013年6月,大盘屡创新低,但它不仅看跌,而且还出现了“满江红”形态,7月再度开盘后也没有大幅补跌,只做出略微调整,就在0.5黄金支撑位获得支撑吗,之后又拉出几个涨停,短期内股价翻了一番,真是一匹黑马。在股价运行到波段高位时,上涨速度改变,主力k线出现“乌云盖顶”和“天堂路”,是明确的卖出信号,若股民能提前读懂k线吗,很容易获得波段利润,之后在合适位置寻找下次操作机会。

  满江红主图指标公式源码到这儿就和大家分享完毕,希望对股民们了解这部分知识能够有所帮助。如若大家还想学习知识,可点击阅读。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top