设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

梅花三弄指标公式及其副图指标源码详解

来源:未知 编辑:admin 时间:2018-03-01
导读: 在股票投资中也有一个指标深受股民喜爱:梅花三弄。今天,赢家财富网站主编就来和大家分享下梅花三弄指标公式及其副图指标源码,希望能对广大股民的实战操作有所帮助。
 

  相信大部分80后、90后都看过马景涛和陈德容主演的电视剧——《梅花烙》系列,在当时看的时候都被他们之间的凄美爱情所感动。其实,在股票投资中也有一个指标深受股民喜爱:梅花三弄。今天,赢家财富网站主编就来和大家分享下梅花三弄指标公式及其副图指标源码,希望能对广大股民的实战操作有所帮助。

梅花三弄指标公式

  【梅花三弄指标公式源码】

  P:=14;

  M:=6;

  AA:= SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);

  DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);

  PDI:= DMP*100/AA;

  MDI:= DMM*100/AA;

  ADX:= MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

  ADXR:=(ADX+REF(ADX,M))/2;

  WMA5:MA(PDI,6);

  WMA10:MA(MDI,5);

  WMA20:MA(ADX,5);

  WMA30:MA(ADXR,5);

  梅花1:(WMA5>=WMA10 AND WMA20>=WMA30 AND ( WMA20-WMA30<1.35 OR WMA5-WMA20<1.35) AND WMA5-WMA10<3.8 AND C>REF(C,1)*1.002 AND WMA10

  梅花2:(WMA5>=WMA10 AND WMA20>=WMA10 AND ( WMA20-WMA10<1.35 OR WMA5-WMA20<1.35) AND WMA5-WMA10<2.8 AND C>REF(C,1)*1.003 AND MAX(WMA20,WMA30)<30)*15,COLOR00FFFF,LINETHICK2;

  梅花3:(WMA5>WMA10*1.01 AND (WMA20>=WMA30 OR WMA5>=WMA30 ) AND ( WMA20-WMA10<3.35 OR WMA5-WMA20<5.35) AND WMA5-WMA10<5.8 AND C>O AND WMA5-WMA30<6.55 AND C>REF(C,1)*1.004 AND MAX(WMA20,WMA30)<25)*15,COLOR0000FF,LINETHICK1;

  AA2:(CROSS(WMA5,WMA10) AND (WMA10-WMA20<2.55 OR WMA20-WMA10<2.5))*5,COLOR0000FF,LINETHICK3;

  【梅花三弄副图指标源码】

  梅花三弄副图指标源码

  M:=10;N:=5;

  VAR1:=(CLOSE-OPEN)/OPEN*100;

  VAR2:=REF(CLOSE,1);

  VAR3:=SMA(MAX(CLOSE-VAR2,0),6,1)/SMA(ABS(CLOSE-VAR2),6,1)*100;

  VAR4:=COUNT(VAR3=1;  VAR5:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);

  VAR6:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,N);

  VAR7:=CROSS(-5,VAR6) AND VAR5<-0.4;

  VAR8:=REF(CLOSE,1);

  VAR9:=SMA(MAX(CLOSE-VAR8,0),5,1)/SMA(ABS(CLOSE-VAR8),5,1)*125;

  VAR10:=SMA(MAX(CLOSE-VAR8,0),10,1)/SMA(ABS(CLOSE-VAR8),10,1)*125;

  VAR11:=MA(CLOSE,10);

  VAR12:=MA(CLOSE,20);

  VAR13:=VAR9<80 AND VAR10<78 AND SUM(VOL/CAPITAL,10)*125>=10 AND CLOSE/LLV(CLOSE,120)<=1.2 AND (CLOSE-LLV(CLOSE,15))/LLV(CLOSE,15)>=0.12 AND CLOSE/OPEN>1.02 AND VAR11>VAR12;

  低位狙击:VAR1>9 AND VAR4 OR VAR7 OR VAR13,COLORRED;

  VAR14:=EXIST(低位狙击,6) AND BARSCOUNT(低位狙击)>=8 AND C/REF(L,2)<0.97 AND NOT(C>O);

  VAR15:=FILTER(VAR14,10);

  补仓救援:IF(VAR15,0.6,0),COLORBBBBBB;

  梅花三弄指标公式源码及副图源码到这儿就和大家分享完毕,希望大家通过阅读本篇文章对该指标有进一步的了解。若大家还想学习其他,请继续关注本栏目的更新。最后,祝大家投资愉快!

 

网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top