设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

解析VOL动量副图指标公式源码

来源:未知 编辑:admin 时间:2018-03-01
导读: 在炒股时我们会用到各式各样的指标公式,可以说在获利的道路上它们功不可没。但你真的了解所有指标吗?真的对所有指标能够熟练应用吗?相信很多人都不能百分百保证吧。
 

  在炒股时我们会用到各式各样的指标公式,可以说在获利的道路上它们功不可没。但你真的了解所有指标吗?真的对所有指标能够熟练应用吗?相信很多人都不能百分百保证吧。所以,为增加大家的知识储备,今天赢家财富网主编会和大家介绍一种新的指标:VOL动量指标。详细内容如下文所示:

  【VOL动量指标副图公式源码】

股票指标公式

  预测量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),COLORCCCCFF,NODRAW;

  STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预测量,0,8,-1),COLORYELLOW;

  【成交量】:=VOL,VOLSTICK,COLORRED;

  成交额亿:=AMOUNT/100000000,NODRAW;

  流通:=CAPITAL/1000000,NODRAW;

  成交流通比:=AMOUNT/CAPITAL/100,NODRAW;

  大盘成交【手】:=INDEXV,COLORFF55FF,NODRAW;

  涨家数:INDEXADV,COLOR0000EE,NODRAW;

  跌家数:INDEXDEC,COLOR00EE00,NODRAW;

  STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.2,0),COLORFF77FF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,2.7,0),COLORFF33FF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,2.1,0),COLORFF55FF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,1,6),COLORFF77FF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.8,0),COLORFF99FF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.5,0),COLORFFBBFF;

  STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,0.1,0),COLORFFDDFF;

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  STICKLINE(CLOSE

  HL10:=WINNER(C/1.1)*V,COLORBLUE;

  {STICKLINE(((C/1.1)*V),HL10,0,3,0),COLORMAGENTA;}

  STICKLINE(HL10>0,0,HL10,3,2),COLORFF0033;{紫罗兰色--攻击量}

  STICKLINE(HL10>0,0,HL10,2.7,0),COLORFF0066;

  STICKLINE(HL10>0,0,HL10,2,1),COLORFF0099;

  STICKLINE(HL10>0,0,HL10,1.6,0),COLORFF00CC;

  STICKLINE(HL10>0,0,HL10,0.5,0),COLORFF00FF;

  HL20:=WINNER(C/1.2)*V;

  {STICKLINE(((C/1.2)*V),HL20,0,2.1,0)COLORYELLOW;}

  STICKLINE(HL20>0,0,HL20,3,2),COLOR0035FF; {黄色--潜入量}

  STICKLINE(HL20>0,0,HL20,2.7,0),COLOR0064FF;

  STICKLINE(HL20>0,0,HL20,2,1),COLOR0093FF;

  STICKLINE(HL20>0,0,HL20,1.6,0),COLOR00C2FF;

  STICKLINE(HL20>0,0,HL20,0.5,0),COLOR00FFFF;

  HL30:=WINNER(C/1.3)*V;

  STICKLINE(((C/1.3)*V),HL30,0,2.5,0),COLORRED;

  STICKLINE(HL30>0,0,HL30,3.2,0),COLOR000066;{红色--拉升量}

  STICKLINE(HL30>0,0,HL30,2,7),COLOR000077;

  STICKLINE(HL30>0,0,HL30,2.1,0),COLOR000099;

  STICKLINE(HL30>0,0,HL30,1.6,0),COLOR0000CC;

  STICKLINE(HL30>0,0,HL30,0.2,0),COLORCC66FF;

  {VOL动能均分量}

  换手:=V*100/CAPITAL;

  主力:=MA(换手,4);

  大户:=MA(换手,9);

  中户:=MA(换手,17);

  散户:=MA(换手,34);

  均量:=(主力+大户+中户+散户)/4;

  主力能量:=(主力-均量);

  大户能量:=(大户-均量);

  中户能量:=(中户-均量);

  散户能量:=(散户-均量);

  DRAWTEXT(V>0 AND ISLASTBAR AND ABS(主力能量),V*0.98,IF(主力能量>0 AND 主力能量>REF(主力能量,1),' 机构+',' 机构-')),COLORYELLOW;

  DRAWTEXT(V>0 AND ISLASTBAR AND ABS(大户能量),V/4*3,IF(大户能量>0 AND 大户能量>REF(大户能量,1),' 大户+',' 大户-')),COLOR0000CC;

  DRAWTEXT(V>0 AND ISLASTBAR AND ABS(中户能量),V/2,IF(中户能量>0 AND 中户能量>REF(中户能量,1),' 中户+',' 中户-')),COLORMAGENTA;

  DRAWTEXT(V>0 AND ISLASTBAR AND ABS(散户能量),V/4,IF(散户能量>0 AND 散户能量>REF(散户能量,1),' 散户+',' 散户-')),COLORCYAN;

  {--------VOL.量能饱和--------}

  N1:=N;

  N2:=N1*1.05;

  N3:=N1+3;

  SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

  量能饱和:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;

  中点:=REFDATE(HHV(V,100)/2,DATE);{量能饱和的变色切换}

  {中点:=REFDATE(HHV(V,240)/2,DATE);}

  STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;

  STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0033FF;

  STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱和,0),COLOR0077FF;

  STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和,0),COLOR0099FF;

  STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和,0),COLOR00DDFF;

  DRAWTEXT(CURRBARSCOUNT=N3,中点*1.7,'量能饱和度'),COLORYELLOW;

  红色拉升:0;黄色潜入啊:0;紫罗蓝攻击:0;

  以上就是VOL动量指标副图公式源码的主要内容,希望对股民们学习这部分知识能有所帮助。如若大家还想学习知识点可点击进入。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top