设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票三叶菩提指标公式源码精讲

来源:未知 编辑:admin 时间:2018-03-01
导读: 股票指标有很多,所以他们各自的指标公式源码也是不一样的,那究竟股票三叶菩提指标公式源码是怎么样的?今天赢家江恩的主编老师就将自己所总结的相关源码与大家进行分享。
 

  股票指标有很多,所以他们各自的指标公式源码也是不一样的,那究竟股票三叶菩提指标公式源码是怎么样的?今天赢家江恩的主编老师就将自己所总结的相关源码与大家进行分享。

  如果我们在百度上搜索股票三叶菩提经常会看到的源码是比较简短的,具体如下:

  A线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

  B线:EMA(REF(A线,1),2),LINETHICK2,COLOR00FFFF;

  趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK2,COLORFF00FF;

股票三叶菩提指标

  除去上面这种简单的三叶菩提指标公式源码之外,赢家江恩的主编老师还收集了一个相对比较强的加强版的指标源码,具体如下:

  简单的三根线:红、黄、紫,红、黄线在紫色线上表示强,红线上穿黄线买入,红线下穿黄色卖出;红、黄色在紫色线下不买。

  A线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

  B线:EMA(REF(A线,1),2),LINETHICK2,COLOR00FFFF;

  趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK2,COLORFF00FF;

  涨停:ZTPRICE(REF(C,1),0.1),COLORYELLOW,NODRAW;跌停:DTPRICE(REF(C,1),0.1),COLORGREEN,NODRAW;

  止赢:REF(C,1)*1.02,COLORFF00FF,NODRAW;止损:REF(C,1)*0.98,COLORGREEN,NODRAW;

  总额:=AMOUNT;

  买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

  买%:=买/AMOUNT*100;

  流入:=AMOUNT*买%/10000000000;

  流出:=AMOUNT/100000000-流入;

  净流:=(流入-流出);

  总额3:=SUM(AMOUNT,3);

  流入3:=SUM(流入,3);

  流出3:=SUM(流出,3);

  净流3:=SUM(流入-流出,3);

  总额5:=SUM(AMOUNT,5);

  流入5:=SUM(流入,5);

  流出5:=SUM(流出,5);

  净流5:=SUM(流入-流出,5);

  总额10:=SUM(AMOUNT,10);

  流入10:=SUM(流入,10);

  流出10:=SUM(流出,10);

  净流10:=SUM(流入-流出,10);

  画:=CONST(FINDHIGH(总额10,0,190,1));

  DRAWTEXT_FIX(1,0.71,0.07,0,'净流入(亿):'),COLOR0080FF;

  DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR0080FF;

  DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR0080FF;

  DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR0080FF;

  DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR0080FF;

  DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

  DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));

  超B:=L2_AMO(0,2)/10000.0;

  大B:=L2_AMO(1,2)/10000.0;

  中B:=L2_AMO(2,2)/10000.0;

  小B:=L2_AMO(3,2)/10000.0;

  超S:=L2_AMO(0,3)/10000.0;

  大S:=L2_AMO(1,3)/10000.0;

  中S:=L2_AMO(2,3)/10000.0;

  小S:=L2_AMO(3,3)/10000.0;

  TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

  大宗进:=(超B)+(大B),NODRAW;

  大宗出:=(超S)+(大S),NODRAW;

  非大宗进:=(中B)+(小B),NODRAW;

  非大宗出:=(中S)+(小S),NODRAW;

  大宗进限制:=IF((超B+大B)=0,0,大宗进);

  大宗出限制:=IF((超S+大S)=0,0,大宗出);

  非大宗进限制:=IF(中B+小B=0,0,非大宗进);

  非大宗出限制:=IF(中S+小S=0,0,非大宗出);

  主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

  散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;

  净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;

  大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

  大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

  大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;

  大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);

  总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

  机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

  大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;

  大单强度限制:=IF(大单强度=0,-100,大单强度);

  大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;

  超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;

  超单强度限制:=IF(超单强度=0,-100,超单强度);

  超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

  DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;

  DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));

  DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));

  DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));

  DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));

  DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;

  DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;

  DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;

  DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;

  主力买力度:=LARGEINTRDVOL*1000/VOL;

  主力卖力度:=LARGEOUTTRDVOL*1000/VOL;

  AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

  DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

  DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

  DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

  DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

  DRAWTEXT_FIX(1,0,0.02,0,'市盈率:'),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.05,0.02,0,CONST(DYNAINFO(39))),COLORYELLOW;

  DRAWTEXT_FIX(1,0.11,0.02,0,'市净率:'),COLOR0080FF;

  DRAWNUMBER_FIX(1,0.16,0.02,0,CONST(C/FINANCE(34))),COLOR0080FF;

  DRAWTEXT_FIX(1,0.21,0.02,0,'每股收益(元):'),COLORFF00FF;

  DRAWNUMBER_FIX(1,0.3,0.02,0,CONST(FINANCE(33))),COLORFF00FF;

  DRAWTEXT_FIX(1,0.00,0.07,0,'莸利比例:'),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.06,0.07,0,CONST(WINNER(C )*100)),COLOR0080FF;

  DRAWTEXT_FIX(1,0.12,0.07,0,'动态PE:'),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.17,0.07,0,CONST(DYNAINFO(39))),COLOR0080FF;

  DRAWTEXT_FIX(1,0.22,0.07,0,'市值:'),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.26,0.07,0,FINANCE(40)/100000000),COLOR0080FF;

  DRAWTEXT_FIX (1,0.31,0.07,0,'公积金(股):'),COLORYELLOW;

  DRAWNUMBER_FIX(1,0.38,0.07,0,FINANCE(18)),COLOR0080FF;

  DRAWTEXT_FIX(1,0.00,0.12,0,'所属板块:'),COLORYELLOW;

  DRAWTEXT_FIX(1,0.06,0.12,0,DYBLOCK),COLOR0080FF;

  DRAWTEXT_FIX(1,0.13,0.12,0,HYBLOCK),COLOR0080FF;

  DRAWTEXT_FIX(1,0.20,0.12,0,GNBLOCK),COLOR0080FF;

  以上的源码就是股票三叶菩提指标公式源码了,相信大家对此已经了解的是非常详细了,如若您想要了解性的文章可以点击进入,最后预祝大家投资愉快。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top