设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

五星连珠指标的使用方法及公式源码精讲

来源:未知 编辑:admin 时间:2018-03-01
导读: 有部分的投资者会使用一种五星连珠指标,那究竟五星连珠指标如何使用?今天赢家财富网的主编人员就为大家带来这个指标的使用方法以及相关的公式源码,希望能够帮助到更多的朋友
 
  有部分的投资者会使用一种五星连珠指标,那究竟五星连珠指标如何使用?今天赢家财富网的主编人员就为大家带来这个指标的使用方法以及相关的公式源码,希望能够帮助到更多的朋友。

  第一:用法

  红柱线是中线指示,其余四色柱线是短线指示;连续发出三个以上短线指示,可以短线买入;连续发出三个以上短线指示后,发出中线指示,可以重仓买入。

  指标当在 在零轴线之上时,指标的 【多头和多均】会显示正值。代表股价的方向和趋势属于形态比较好!反之如果在零轴之下【多头和多均】会显示负值,标示股价是弱势形态! 这样可以根据正负值来来看本只股价的强弱程度!

五星连珠走势图.jpg

  第二、源码

  k2:=EMA(c,5);

  k3:=EMA(c,10);

  k5:=EMA(c,30);

  k6:=2*(k2-k5);

  k7:=2*(k2-k3);

  k8:=2*(k7+k6);

  中线指示:STICKLINE(CROSS(k8,0),0,40,8,0),COLORRED;

  p1:= ma(close,2);

  p2:= ma(close,5);

  diff :=ema(close,12) - ema(close,26);

  dea :=ema(diff,9);

  vma1:=ma (vol,2)/100000;

  vma2:=ma(vol,5)/100000;

  ppday:= barslast(cross(p1,p2));

  vvday:= barslast(cross(vma1,vma2));

  macdday:= barslast(cross(diff,dea));

  A1:=BARSLAST(ref(cross(diff,dea),1));

  金叉:if(ref(c,A1+1)>c and ref(diff,A1+1)

  sjcjd:= if((ppday<=3 and vvday<=3 and macdday<=3)and (diff<0),1,0);

  STICKLINE(sjcjd,50,60,6,0),colorwhite,linethick2;

  短趋势:

  =((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50);

  Var2:=(2*CLOSE+HIGH+LOW+OPEN)/5;

  Var3:=LLV(LOW,34);

  Var4:=HHV(HIGH,34);

  长趋势:=EMA((Var2-Var3)/(Var4-Var3)*100,13),color00ff00;

  判断底:SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*15;

  Var5:=CROSS(短趋势,长趋势)AND 长趋势<25;

  STICKLINE(Var5,60,70,8,0) ,colorgreen;

  XX:=((((CLOSE-MA(CLOSE,34))/MA(CLOSE,34))*100)*5);

  B001:=(((((CLOSE-MA(CLOSE,42))/MA(CLOSE,42)))*100)*5);

  B002:=(((((CLOSE-MA(CLOSE,67))/MA(CLOSE,67)))*100)*5);

  B003:=(((XX+B001)/2)-B002);

  B004:=(((0-100)*(Var4-CLOSE))/(Var4- Var3));

  B005:=(((0-100)*(HHV(HIGH,42) - CLOSE))/(HHV(HIGH,42) - LLV(LOW,42)));

  B006:=(((0-100)*(HHV(HIGH,72) - CLOSE))/(HHV(HIGH,72) - LLV(LOW,72)));

  B007:=EMA((((B004+B005)/2)-B006),6);

  B008:=REF(CLOSE,1);

  B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);

  B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);

  B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);

  多头:EMA(((((B009 + B010)/2) - B011) * 5),6);

  空头:=(((-1*((B007 + B003) + 多头))/3) * 1.5);

  多均:EMA(多头,4);

  空均:=EMA(空头,4);

  C026:=WINNER(CLOSE);

  W:=(DMA(C026,(VOL/CAPITAL)) * 100);

  XD1:=EMA(W,6);

  庄家控盘:((W-XD1)*15),COLORSTICK,LINETHICK2;

  STICKLINE(cross(多头,空均),80,70,8,0),COLORYELLOW;

  Varb1:=(2*CLOSE+HIGH+LOW)/4;

  Varb2:=LLV(LOW,34);

  Varb3:=HHV(HIGH,34);

  Varb4:=ma(HIGH,8);

  xx1:=EMA((Varb1-Varb2)/(Varb3-Varb2)*100,13);

  yy:=EMA(0.667*REF(xx1,1)+0.333*xx1,2) , ;

  STICKLINE(CROSS(xx1,20) AND yyref(Varb4,1),70,80,8,0),COLORFF0000;

  逃顶:IF(FILTER(CROSS(YY,XX) AND xx>80 ,3),70,90),COLORFF0000;

  DRAWTEXT(CROSS(多头,多均)AND 多均<-15,多均,'☆'),COLORRED;

  DRAWTEXT(CROSS(多均,多头)AND 多均>35,多均+7,'☆'),COLOR00FF00;

  分析家的(对庄家控盘进行了改动,与飞狐不完全一样):

五星连珠走势图2.jpg

  {使用方法:

  1 红柱线是中线指示

  2 其余四色柱线是短线指示

  3连续发出三个以上短线指示,可以短线买入.

  4连续发出三个以上短线指示后,发出中线指示,可以重仓买入.}

  k2:=EMA(c,5);

  k3:=EMA(c,10);

  k5:=EMA(c,30);

  k6:=2*(k2-k5);

  k7:=2*(k2-k3);

  k8:=2*(k7+k6);

  中线指示:STICKLINE(CROSS(k8,0),0,40,8,0),COLORRED;

  p1:=ma(close,2);

  p2:=ma(close,5);

  diff:=ema(close,12) - ema(close,26);

  dea:=ema(diff,9);

  vma1:=ma(vol,2)/100000;

  vma2:=ma(vol,5)/100000;

  ppday:= barslast(cross(p1,p2));

  vvday:= barslast(cross(vma1,vma2));

  macdday:= barslast(cross(diff,dea));

  A1:=BARSLAST(ref(cross(diff,dea),1));

  金叉:if(ref(c,A1+1)>c and ref(diff,A1+1)

  sjcjd:= if((ppday<=3 and vvday<=3 and macdday<=3)and (diff<0),1,0);

  STICKLINE(sjcjd,50,60,6,0),colorwhite,linethick2;

  短趋势:

  =((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50);

  Var2:=(2*CLOSE+HIGH+LOW+OPEN)/5;

  Var3:=LLV(LOW,34);

  Var4:=HHV(HIGH,34);

  长趋势:=EMA((Var2-Var3)/(Var4-Var3)*100,13);

  判断底:SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*15;

  Var5:=CROSS(短趋势,长趋势)AND 长趋势<25;

  STICKLINE(Var5,60,70,8,0) ,colorgreen;

  XX:=((((CLOSE-MA(CLOSE,34))/MA(CLOSE,34))*100)*5);

  B001:=(((((CLOSE-MA(CLOSE,42))/MA(CLOSE,42)))*100)*5);

  B002:=(((((CLOSE-MA(CLOSE,67))/MA(CLOSE,67)))*100)*5);

  B003:=(((XX+B001)/2)-B002);

  B004:=(((0-100)*(Var4-CLOSE))/(Var4- Var3));

  B005:=(((0-100)*(HHV(HIGH,42) - CLOSE))/(HHV(HIGH,42) - LLV(LOW,42)));

  B006:=(((0-100)*(HHV(HIGH,72) - CLOSE))/(HHV(HIGH,72) - LLV(LOW,72)));

  B007:=EMA((((B004+B005)/2)-B006),6);

  B008:=REF(CLOSE,1);

  B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);

  B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);

  B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);

  多头:EMA(((((B009 + B010)/2) - B011) * 5),6);

  空头:=(((-1*((B007 + B003) + 多头))/3) * 1.5);

  多均:EMA(多头,4);

  空均:=EMA(空头,4);

  Va1:=EMA(EMA(CLOSE,13),13);

  庄家控盘:(Va1-REF(Va1,1))/REF(Va1,1)*3000,POINTDOT;

  STICKLINE(庄家控盘<0,庄家控盘,0,4,0),colorffff00;

  STICKLINE(庄家控盘>0,庄家控盘,0,4,0),colorred;

  STICKLINE(cross(多头,空均),80,70,8,0),COLORYELLOW;

  Varb1:=(2*CLOSE+HIGH+LOW)/4;

  Varb2:=LLV(LOW,34);

  Varb3:=HHV(HIGH,34);

  Varb4:=ma(HIGH,8);

  xx1:=EMA((Varb1-Varb2)/(Varb3-Varb2)*100,13);

  yy:=EMA(0.667*REF(xx1,1)+0.333*xx1,2);

  STICKLINE(CROSS(xx1,20) AND yyref(Varb4,1),70,80,8,0),COLORFF0000;

  逃顶:IF(FILTER(CROSS(YY,XX) AND xx>80 ,3),70,90),COLORFF0000;

  DRAWTEXT(CROSS(多头,多均)AND 多均<-15,多均,'☆'),COLORRED;

  DRAWTEXT(CROSS(多均,多头)AND 多均>35,多均+7,'☆'),COLOR00FF00;

  以上就是关于五星连珠指标公式源码的介绍,相信大家已经了解,想要学习更多的股票指标源码敬请关注本栏目的更新,如若想要学习的应用可点击进入,最后预祝大家投资愉快。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top