设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

星光主图指标公式源码及相应的解析

来源:未知 编辑:admin 时间:2018-03-01
导读: 股票中有很多的技术指标进行公司的分析,星光指标就是一种趋势指标之一。那星光指标如何应用?星光主图指标公式源码是怎么样的?如果您对此还不清楚的话,今天我们就来进行详细的
 
  股票中有很多的技术指标进行公司的分析,星光指标就是一种趋势指标之一。那星光指标如何应用?星光主图指标公式源码是怎么样的?如果您对此还不清楚的话,今天我们就来进行详细的讲解,希望能够对大家有所帮助。

  一、概述

  星光指标其实就是根据均线系统而进行改变的,它的核心就是,有一条修改了数据的甲醛均线来确定的趋势方向,因为这个指标的样子非常像星星,所以就起名为星光指标。

  二、运用

  趋势追踪:当指标提示“多”时,表示现在趋势为多。

  当指标提示“空”时,表示现在趋势为空。

  趋势过滤:当K线变成白色时,系统提示的信号可能为虚假信号,以规避操作或者进行平仓等待系统给出新信号。

星光主图指标.jpg

  三、星光主图指标公式

  M1:MA(CLOSE,3);

  M2:MA(CLOSE,20);

  生命线:MA(CLOSE,89),LINETHICK2;

  牛熊线:MA(CLOSE,321),COLORWHITE,POINTDOT,LINETHICK4;

  保护价:(OPEN+REF(C,1)+REF(C,2))/3,NODRAW;

  止损:=(REF(H,1)+REF(L,1))/2,NODRAW,COLORGREEN;

  中心价:=(O+C)/2;

  多头:IF(M2>=REF(M2,1),M2,DRAWNULL),COLORRED,LINETHICK2;

  空头:IF(M2

  DT:=CROSS(M1,M2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;

  DRAWTEXT(DT,(LOW*0.98)*(1),'买'),COLORWHITE;

  DRAWICON(DT,(LOW*0.99)*(1),13);

  {逃顶}

  V1:=(REF(HIGH,1)+REF(LOW,1))/2;

  V2:=MA(CLOSE,21)+2*STD(CLOSE,21);

  DRAWICON(CROSS(V1,V2),HIGH*1.00,6);

  DRAWTEXT(CROSS(V1,V2),HIGH*1.01,'卖'), COLORGREEN;

  V3:=REF(CLOSE,1);

  V4:=SMA(MAX(CLOSE-V3,0),7,1)/SMA(ABS(CLOSE-V3),7,1)*100;

  V5:=CROSS(89,V4);

  V6:=FILTER(V5,4);

  DRAWICON(V6,HIGH*1.00,2);

  DRAWTEXT(V6,HIGH*1.01,'卖'), COLORGREEN;

  {划线}

  A1:=BARSLAST(CROSS(MA(C,10),MA(C,5)));

  C1:=REF(MA(C,5),A1);

  STICKLINE(CURRBARSCOUNT<=CONST(A1)+1 AND A1>=0, C1,C1,-1,0),COLORGREEN;

  {肉夹馍}

  VAR110:=REF(C,2)>REF(O,2);

  VAR120:=(REF(C,2)-REF(C,3))/REF(C,3)>0.02;

  VAR210:=REF(C,1)

  VAR310:=C>O AND C>REF(O,1) AND C>REF(C,2) ;

  VAR320:=V>REF(V,2) AND V>REF(V,1);

  VAR330:=((H-C)/(H-L))<0.3;

  VAR410:=VAR110 AND VAR120 AND VAR210 AND VAR310 AND VAR320 AND VAR330;

  DRAWTEXT(VAR410,(LOW*1.02)*(1),'肉夹馍 '),COLORYELLOW;

  DRAWICON(VAR410,(LOW*1.01)*(1),5);

  {概念板块}

  DRAWTEXT_FIX(1,0.00,0.04,0,'【概念板块】')COLORFF00FF;

  Z1:=STRCAT(DYBLOCK,' ');

  Z2:=STRCAT(Z1,HYBLOCK);

  Z3:=STRCAT(Z2,FGBLOCK);

  Z4:=STRCAT(Z3,' ');

  DRAWTEXT_FIX(1,0.09,0.04,0,STRCAT(Z4,GNBLOCK)),COLORFF00FF;

  DRAWTEXT_FIX(1,0.00,0.12,0,'【主题投资】'),COLOR0000FF;

  DRAWTEXT_FIX(1,0.09,0.12,0,EXTERNSTR(0,1)),COLOR0000FF;{注意:我的数据号是1}

  DRAWTEXT_FIX(1,0.00,0.20,0,'【主营业务】'),COLORGREEN;

  DRAWTEXT_FIX(1,0.09,0.20,0,EXTERNSTR(0,2))COLORGREEN;{这个数据号是2};

  星光主图指标公式源码的相关内容就为大家讲解到这里,相信大家已经能够掌握住了,如若您想要学习可点击进入,最后希望大家在今天的交易日中能够有更多的收获。


网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top