设为首页 - 加入收藏
广告 1000x90
您的当前位置:最权威的股票期权资讯平台 > 股票知识 > 股票炒股技巧 > 正文

股票乾坤三牛指标的源码解析

来源:未知 编辑:admin 时间:2018-03-01
导读: 在通达信软件中有一种股票乾坤三牛指标受到部分投资者的亲睐,很多投资者都想要得知股票乾坤三牛指标的源码,今天小编就带来自己所学习到的关于该指标的源码及源码解析。
 
  在通达信软件中有一种股票乾坤三牛指标受到部分投资者的亲睐,很多投资者都想要得知股票乾坤三牛指标的源码,今天小编就带来自己所学习到的关于该指标的源码及源码解析。

  股票乾坤三牛指标在软件中有三条曲线所组成的,同时还有买卖以及牛股的相关提示,当指标提示的出来的时候,投资者就应该进行关注了,如果持有的提示处卖了那么就应该注意清仓的,如果是还未买入,指标提示买入了那么就可以进行进仓了。该指标的图形如下。

股票乾坤三牛指标

  【股票乾坤三牛指标源码】

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*10;

  K:SMA(RSV,3,1);

  D:SMA(K,3,1);

  J:3*K-2*D;

  IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK2;

  IF(K>90,K,DRAWNULL),COLOR0000FF,LINETHICK2;

  IF(D>85,D,DRAWNULL),COLORFFFF11,LINETHICK2;

  2, COLORCC6633,LINETHICK2;

  5, POINTDOT;

  10,COLORRED,LINETHICK2;

  VAR1:=C-REF(C,1);

  VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);

  MA5:=EMA(C,5);

  MA13:=EMA(C,13);

  UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;

  DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;

  BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND REF(DOWN,1)REF(DOWN,1);

  STICKLINE(UP,0,0.2,3,0),COLOR0000FF;

  STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;

  STICKLINE(BT,0,3,2,0),COLOR000088;

  STICKLINE(BT,0,3,1,0),COLOR0000CC;

  STICKLINE(BT,0,3,0.22,0),COLOR0000FF;

  DRAWTEXT(BT,3,'短牛'),COLOR0000FF;

  TJ1:=REF(DOWN,1)REF(DOWN,1) AND C

  STICKLINE(TJ1,0,2,3,0),COLOR880088;

  STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;

  STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;

  STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;

  DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;

  HR:=HHV(HIGH,55);

  HRY:=LLV(LOW,55);

  HRY11:=HR*HRY;

  HRY33:=SQRT(HRY11);

  TJ2:=REF(DOWN,1)REF(DOWN,1) AND C

  STICKLINE(TJ2,0,1,5,0),COLOR008888;

  STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;

  STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;

  STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;

  DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;

  ST:=REF(UP,1)>REF(UP,2) AND DOWN

  STICKLINE(ST,10,11.05,5,0),COLOR008800;

  STICKLINE(ST,10,11.05,2,0),COLOR00AA00;

  STICKLINE(ST,10,11.05,1,0),COLOR00CC00;

  STICKLINE(ST,10,11.05,0.2,0),COLOR00FF00;

  DRAWTEXT(ST,10,'卖'),COLORFFFFFF;

  DRAWICON(BT AND TJ1 AND TJ2,5,25);DRAWTEXT_FIX(C>O,0.01,0.9,0,'WWW.CXH99.COM'),COLORRED;

  【股票乾坤三牛指标源码解析】

  RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*10

  输出K:RSV的3日[1日权重]移动平均

  输出D:K的3日[1日权重]移动平均

  输出J:3*K-2*D

  如果J<0,返回J,否则返回无效数,画绿色,线宽为2

  如果K>90,返回K,否则返回无效数,COLOR0000FF,线宽为2

  如果D>85,返回D,否则返回无效数,COLORFFFF11,线宽为2

  2, COLORCC6633,线宽为2

  5, POINTDOT

  10,画红色,线宽为2

  VAR1赋值:收盘价-昨收

  VAR2赋值:100*VAR1的6日指数移动平均的6日指数移动平均/VAR1的绝对值的6日指数移动平均的6日指数移动平均

  MA5赋值:收盘价的5日指数移动平均

  MA13赋值:收盘价的13日指数移动平均

  UP赋值:当满足条件最低价=上次MA13上穿MA5距今天数+1日内最低价的最低值时,在上次MA13上穿MA5距今天数+1日内最低价的最低值位置画直线起点,当满足条件最高价=上次MA5上穿MA13距今天数+1日内最高价的最高值时,在上次MA5上穿MA13距今天数+1日内最高价的最高值位置画直线终点,0表示是否延长.,COLOR0000FF

  DOWN赋值:当满足条件最高价=上次MA5上穿MA13距今天数+1日内最高价的最高值时,在上次MA5上穿MA13距今天数+1日内最高价的最高值位置画直线起点,当满足条件最低价=上次MA13上穿MA5距今天数+1日内最低价的最低值时,在上次MA13上穿MA5距今天数+1日内最低价的最低值位置画直线终点,0表示是否延长.,COLOR00FF00

  输出BT:(2日内VAR2的最低值=7日内VAR2的最低值 AND 统计2日中满足VAR2<0的天数 AND VAR2上穿VAR2的2日简单移动平均) AND 昨日DOWN<2日前的DOWN AND UP>昨日DOWN

  当满足条件UP时,在0和0.2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF

  当满足条件DOWN时,在0和0.2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00

  当满足条件BT时,在0和3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000088

  当满足条件BT时,在0和3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000CC

  当满足条件BT时,在0和3位置之间画柱状线,宽度为0.22,0不为0则画空心柱.,COLOR0000FF

  当满足条件BT时,在3位置书写文字,COLOR0000FF

  TJ1赋值:昨日DOWN<2日前的DOWN AND UP>昨日DOWN AND 收盘价<21日内最高价的最高值*0.82

  当满足条件TJ1时,在0和2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR880088

  当满足条件TJ1时,在0和2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAA00AA

  当满足条件TJ1时,在0和2位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLORCC00CC

  当满足条件TJ1时,在0和2位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORFF00FF

  当满足条件TJ1时,在2位置书写文字,COLORFF00FF

  HR赋值:55日内最高价的最高值

  HRY赋值:55日内最低价的最低值

  HRY11赋值:HR*HRY

  HRY33赋值:HRY11的开方

  TJ2赋值:昨日DOWN<2日前的DOWN AND UP>昨日DOWN AND 收盘价

  当满足条件TJ2时,在0和1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR008888

  当满足条件TJ2时,在0和1位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00AAAA

  当满足条件TJ2时,在0和1位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CCCC

  当满足条件TJ2时,在0和1位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FFFF

  当满足条件TJ2时,在1位置书写文字,COLOR00FFFF

  ST赋值:昨日UP>2日前的UP AND DOWN<昨日UP

  当满足条件ST时,在10和11.05位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR008800

  当满足条件ST时,在10和11.05位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00AA00

  当满足条件ST时,在10和11.05位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CC00

  当满足条件ST时,在10和11.05位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FF00

  当满足条件ST时,在10位置书写文字,COLORFFFFFF

  当满足条件BTANDTJ1ANDTJ2时,在5位置画25号图标。

  股票乾坤三牛指标的源码解析就为大家讲解到这里,相信大家对此已经掌握了,只有通过一点点的学习,你的投资技能才会得到提升,进而才能从这个市场中赚钱。


上一篇:没有了
下一篇:牵牛波段指标公式源码的相关分享

网友评论:

闽ICP备17026384号 ICP备案

Copyright © 2018-2020 REYO.CC 个股期权通 版权所有 Power by reyo.cc

Top